Support » Plugin: MailPoet Newsletters (Previous) » Images not displaying in email, MailPoet Beta 3

  • The pictures display fine when I click “Open this email in your web browser” but inside the email it shows broken image links.

    I have followed all the instructions for the file permissions for /wp-content/uploads/wysija ….going so far as to recursively make everything under /wp-content/uploads as 775 permissions I deactivated, deleted the plugin, reinstalled and created new letter and it still persists. All the example folders/files are out there in the wysija directory.. Neither them nor any of my own media will display in email, but again it displays fine on the web.

    Just as an FYI, I’m running on nginx, not apache. Don’t know if that make a difference.

    • This topic was modified 3 years, 8 months ago by mlaw93.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter mlaw93

    (@mlaw93)

    Okay, some more trouble shooting information.

    The email went to Microsoft Outlook for MacOS. And images display broken.

    BUT, if I save the email as a “.eml” and then reopen the email using the MacOS native Email client, the images show up.

    So my guess is that the Microsoft Outlook for MacOS isn’t interpreting something correctly.

    Any ideas?

    Plugin Author MailPoet

    (@wysija)

    Sorry, we haven’t heard of any issues related to that. It looks like some security setting on these email clients. Try with MailPoet 3 as well: https://wordpress.org/plugins/mailpoet/

    Also, make sure your website is not running any security plugin that contains a feature called “Hotlink protection”. That feature is also available on your server’s control panel. Disabling it might help.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Images not displaying in email, MailPoet Beta 3’ is closed to new replies.