Support » Plugin: WooCommerce » Images not displaying correctly

  • wererich1

    (@wererich1)


    I installed several different WooCommerce themes trying to see if the issue with my image displaying properly has to do with the themes. As far as I can tell it’s not. I’ve used only free ones because I’m not willing to pay unless it works. My issue is that when you click on shop, the thumbnail cuts off the image. It’s almost like it’s blowing it up and then cutting it off. I’ve looked at other sites using the themes and the problem is apparent on some but not on others. It’s supposed to resize your images for thumbnail, catalog, and single page but the problem really lies with the thumbnail. Here is the site. I only have one image actually loaded up. http://www.centsity.com/ Any suggestions or help would be greatly appreciated. Right now you will see TwentySeventeen installed because it’s the last thing I switched over to but scroll down to the only product and that’s how it looks on WooCommerce too.

    • This topic was modified 3 months ago by  wererich1.
Viewing 6 replies - 1 through 6 (of 6 total)
  • @wererich1

    Thank you for writing the WooCommerce plugin forum.

    In the screenshot, the image of the bar of soap doesn’t currently look cropped. Did you fix it to some extent? Or can you explain in more detail what you mean by it being cut off?

    Screenshot:
    2017 07 19 Centsity Making Sense out of your cents

    Regards,

    Morgan

    No, I’m sorry. It’s not fixed. What you are seeing is a “blown up” version of the soap and then cropped off. The sides are not visible. This bar of soap has rounded edges.

    Yes I can see the problem. The link to the image being displayed is:
    https://i0.wp.com/www.centsity.com/wp-content/uploads/2017/07/Green-Tea.jpg?resize=262%2C325
    which has the cropped corners.

    Whereas the original image is:
    https://i0.wp.com/www.centsity.com/wp-content/uploads/2017/07/Green-Tea.jpg
    which has nice rounded corners.

    WooCommerce doesn’t do images this way, and its probably not a theme feature, so I suspect is coming form one of your plugins. There is an easy test – temporarily deactivate all other plugins and check. I don’t think you’ll see the problem then. Reactivate plugins one-by-one to try to identify which one is adding the ?resize parameter which is not working fully.

    If the problem persists, please post a system report as advised here:
    https://wordpress.org/support/topic/before-posting-gather-the-following-details/

    Thank you lorro. I went ahead and deactivated all plug-ins – to include woocommerce because that was the last one and it was still displaying that way. Then I decided to delete woocommerce and reinstall just in case. It was an excellent idea! I was hoping it would work but it’s till doing the same thing as can be seen here (I’ve added 3 soaps now and they appear awful):

    http://www.centsity.com

    I would love to post in that link you mentioned but it has been closed up for a year. No replies allowed. I’ve contacted my server company and they don’t understand the problem and don’t provide support for wordpress/woocommerce.

    The other post tells us how to get a system report. Having got it, you would post it here in this thread. It may have some clues.

    Anyway, something has changed since last time I looked because the “?resize” parameter is no longer present on the image links.

    Could we look at something else. If you go to:
    Dashboard > WooCommerce > Settings > > Products tab > Display, then the Product Images section down the bottom of that screen – are the “Hard crop” boxes ticked?

    If they are ticked, un-tick them then regenerate your thumbnails using this plugin:
    https://wordpress.org/plugins/regenerate-thumbnails/
    Does that make a difference?

    @wererich1

    I’d agree with @lorro that the the “Hard crop” boxes settings will be relevant in this case — will you share what they’re currently set to?

    Also, would you be able to post here, or post a link to, the original image that is being used for that picture of the bar of soap (the “PRÉ de PROVENCE…- AGRUMES (CITRUS FRUIT)…” one discussed above)?

    (I can’t currently see the centsity site right now, but instead see a Coming Soon page.)

    @wererich1, additionally, if you’ve already found a solution, then will you start to mark this thread as ‘Resolved’? (including some solution detail)

    Or if there’s still concern, then will you update how it is?

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.