Support » Plugin: WebP Converter for Media - Convert WebP & Optimize Images » Images not converted to webp

  • Resolved cjlim

    (@cjlim)


    I tried uploading an image but i don’t see any webp images generated in “uploads-webpc” folder.

    Checked my server config and all looks good (what needs to be enabled are all enabled).

    The Regenerate All tool also fails with error “An error occurred while connecting to REST API. Please try again.”.
    Looking at network call tab, i noticed the call “/wp-json/webp-converter/v1/paths?_wpnonce=170d438770” failed with a 404 error.
    The response given was “message: No route was found matching the URL and request method”.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi @cjlim,

    Thank you for your message.

    Tell me please have you read the plugin FAQ? There are answers to many questions. Remember to always read the FAQ of the plugin and other similar threads before adding a thread in the support section.

    Many problems could be solved without adding a thread, because the issue has already been raised in the FAQ or another thread. And that saves a lot of time.

    Try to understand me, please. There are many people who write with various problems and try to help them all. There is even a special question in the FAQ that sets out what I need to help you.

    Then help is much faster. Please appreciate your and my time. With little information I can do little. I will be grateful for your cooperation.

    Thread Starter cjlim

    (@cjlim)

    Indeed I have. How else would I have checked server config and run developer tools to get http error and error message?

    But your reply sounds like I’m missing something, which is definitely possible. In which case, a quick hint/point out would be appreciated.

    I don’t see how this reply of yours does any help for both of us.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    I explained everything in the message above. Please contact the administrator of your server and give him all the information I have given you.

    Please return to me with a reply from them.

    Thread Starter cjlim

    (@cjlim)

    1. Do you have any error on the plugin settings page?
    No Error

    2. URL of your website. If your site is not publicly available, add it to test environment.
    https://www.yourblazeguard.com

    3. Does your server meet the technical requirements described in the FAQ? Please send configuration of your server (link to it can be found on the settings page of plugin in the section “We are waiting for your message”) – please take a screenshot of the ENTIRE page and send it to me.
    Yes. phpinfo can be downloaded from: https://www.dropbox.com/s/hlichvmzjhw7nqg/phpinfo.pdf?dl=0

    4. Do you use CDN?
    No

    5. Check if in /wp-content/uploads-webpc directory are all files that should be converted.
    No

    Run Google Chrome and enable Dev Tools (F12).
    Response of https://www.yourblazeguard.com/wp-json/webp-converter/v1/paths?_wpnonce=170d438770
    {"code":"rest_no_route","message":"No route was found matching the URL and request method","data":{"status":404}}

    Please check also if you have any errors in /wp-content/debug.log?
    No Error

    7. Content of your .htaccess files from directories /wp-content/uploads and /wp-content/uploads-webpc (pasting the code using the CODE shortcode in the editor).
    */wp-content/uploads*

    
    text/x-generic .htaccess ( ASCII text )
    # BEGIN WebP Converter
    # ! --- DO NOT EDIT PREVIOUS LINE --- !
    <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteCond %{HTTP_ACCEPT} image/webp
      RewriteCond %{DOCUMENT_ROOT}/wp-content/uploads-webpc/$1.jpg.webp -f
      RewriteRule (.+)\.jpg$ /wp-content/uploads-webpc/$1.jpg.webp [NC,T=image/webp,E=cache-control:private,L]
      RewriteCond %{HTTP_ACCEPT} image/webp
      RewriteCond %{DOCUMENT_ROOT}/wp-content/uploads-webpc/$1.jpeg.webp -f
      RewriteRule (.+)\.jpeg$ /wp-content/uploads-webpc/$1.jpeg.webp [NC,T=image/webp,E=cache-control:private,L]
      RewriteCond %{HTTP_ACCEPT} image/webp
      RewriteCond %{DOCUMENT_ROOT}/wp-content/uploads-webpc/$1.png.webp -f
      RewriteRule (.+)\.png$ /wp-content/uploads-webpc/$1.png.webp [NC,T=image/webp,E=cache-control:private,L]
    </IfModule>
    # ! --- DO NOT EDIT NEXT LINE --- !
    # END WebP Converter
    

    */wp-content/uploads-webpc*

    text/x-generic .htaccess ( ASCII text )
    # BEGIN WebP Converter
    # ! --- DO NOT EDIT PREVIOUS LINE --- !
    <IfModule mod_mime.c>
      AddType image/webp .webp
    </IfModule>
    <IfModule mod_expires.c>
      ExpiresActive On
      ExpiresByType image/webp "access plus 1 year"
    </IfModule>
    # ! --- DO NOT EDIT NEXT LINE --- !
    # END WebP Converter

    8. What plugin version are you using? If it is not the latest then update and check everything again.
    1.2.5

    9. Used WordPress version.
    5.4.1

    10. A list of all the plugins you use. Have you tried checking the plugin operation by turning off all others? If not, please try whenever possible.
    the list is too long to test.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Thank you for your answers.

    Entering the URL of this endpoint, I have a error 403 – rest_cookie_invalid_nonce and this is very normal, because my Cookie nonce is wrong.

    Can you turn off all the plugins and test it again? Also try using the default WordPress theme.

    Thread Starter cjlim

    (@cjlim)

    Thanks for the tip. Switching back to default theme does work in terms of regenerating all images.
    All problems solved. I can see the webp images created in the uploads-webbpc folder as well.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    So everything works?

    Thread Starter cjlim

    (@cjlim)

    yes, it does now.
    all because of the theme I was using.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    In that case, I’m closing the thread.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Images not converted to webp’ is closed to new replies.