• Resolved luxworx

    (@luxworx)


    Hello Mateusz,
    After installing Your plugin and running it, all of my images on the website http://gsu-it.pl/ are missing.
    They are on the servers and I can view them, but they are not displaying on the website.
    What can be the reason?

    Settings page: https://nimb.ws/2QjIKs
    Server config: https://nimb.ws/c4YBX1
    Serwer at: nazwa.pl

    WordPress 5.7.2
    Webp plugin: 3.0.1

    • This topic was modified 1 month ago by luxworx.
    • This topic was modified 1 month ago by luxworx.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hello @luxworx,

    Thnaks for your message.

    Can you send the contents of .htaccess files from the following locations?

    • /.htaccess
    • /wp-content/.htaccess
    • /wp-content/uploads/.htaccess

    Do you use any more .htaccess files in directories higher than public_html?

    Best,
    Mateusz

    Thread Starter luxworx

    (@luxworx)

    public html: https://wtools.io/paste-code/b5bg
    wp-content: https://wtools.io/paste-code/b5bj
    uploads: https://wtools.io/paste-code/b5bm

    I don’t have access to folders higher than public_html

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @luxworx, please try turning off the plugins one by one and check which one of them will fix the problem with images:

    • iThemes Security
    • Hummingbird
    • WP Performance Score Booster

    After disabling each plugin, do the following:

    • Save the changes in the admin panel, in the Settings -> Permalinks tab
    • Go to the WebP plugin settings and save the changes
    • Check if the images are working properly
    Thread Starter luxworx

    (@luxworx)

    Disabling the plugins didn’t solve the issue.
    I’ve tried to remove everything except wordpress settings in .httacces and it didn’t help also 🙁

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @luxworx Thanks for your tests. Try adding the following code to the functions.php file in your theme directory:

    add_filter( 'webpc_uploads_prefix', function( $prefix ) {
        return '/';
    } );
    Thread Starter luxworx

    (@luxworx)

    It didn’t solve the issue.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @luxworx Please send me again after adding this filter the screenshots of the plugin settings (both tabs) and the content of the .htaccess files.

    Thread Starter luxworx

    (@luxworx)

    Server configuration: https://nimb.ws/zIQjOq
    Plugin: configuration: https://nimb.ws/592MKn
    public_html: https://wtools.io/paste-code/b5b2
    wp-content, and uploads: htacess files empty.

    Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    @luxworx Please contact me via e-mail: mateusz[at]gbiorczyk[dot]pl. I will try to help you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.