Support » Plugin: AMP for WP - Accelerated Mobile Pages » Images loading problem

  • Resolved shreen2008

    (@shreen2008)


    Hello.
    When I click on any image, it is doing the default 404 behaviour.
    Here it is redirecting to my home page.
    What is wrong?

    Note:

    The older pages seem to work normal.
    Actually I made a change in the Yoast plugin.
    I am redirecting images to their media urls, instead of their posts.

    • This topic was modified 1 year ago by shreen2008. Reason: further notes

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Contributor ampforwp

    (@ampforwp)

    Hi @shreen2008,

    Will you please tell me how you are adding the images in the non-amp version because if I hover on the image it showing the different path – https://monosnap.com/file/MMzFvBcRUp6MVEKT203JlIIG49bjUv and if I click on it it’s showing the image path.

    Please let me know

    shreen2008

    (@shreen2008)

    Hello.
    Let’s discuss the scenario for this particular post.
    In the post, the image display options are set to “Attachment URLs”.
    But in Yoast plugin, I set to redirect all image url to the attachment itself (that mean to “Media urls”).

    I think this problem will be solved if I set the “Attachment url” to “Media url” just like in other posts.

    I think its not a problem with your plugin.
    But the settings I have chosen and Yoast plugin settings.
    Thanks for your answer.

    shreen2008

    (@shreen2008)

    Hello,
    As described above, I made the change from “Attachment Page” to “Media url”.
    Now the problem seems to be resolved.
    Is that how the images are supposed to behave after clicking an image in AMP pages.
    Please let me know.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Images loading problem’ is closed to new replies.