Support » Plugin: Fix Media Library » Images in uploads not displayed in media-library

  • Resolved presscode

    (@saschinger)


    The posts of this site are being created by importing content from external CMS. Each new posts images are directly uploaded into /wp-content/uploads.

    I was hoping that “Fix Media Library” would help to “synchronize” the content of /uploads with the media-library, but seems not to work. At least I have run a fix process with this plugin and checked the library afterwards. But none of the images from uploads folders were displayed.

    I may have misunderstood the plugins feature, so I wonder if you could please help me clarify or even help me to sync uploads images with media-library?

    Thank you and kind regards,
    Sascha

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author wowpress.host

    (@wowpresshost)

    Hi,

    That depends on which images are you talking about.

    I see you have a lot of images taken from http://brainstormclub.net/assets/ – those are external and are not touched.

    Homepage contains looks-valid images like https://dev-oxygen.brainstormclub.net/wp-content/uploads/2018/08/LAN_Index.jpg and those should be handled well. Just make sure you have “Images with weak references” option set to “Add to Media Library” if those images are in folder but not in Media Library.

    Also I noticed you are working on staging environment. Check that you have correct URLs https://dev-oxygen.brainstormclub.net/ set at Settings->General page so that WordPress and all plugins know which links are external and which are own.

    If still doesn’t work – contact our team at https://wowpress.host/professional-services/ with website credentials and our team will check if plugin should be enhanced.

    Hey, thank you for your prompt reply!

    We have already changed our workaround to import these posts incl. their content- & featured-images, so those that seem to be handled well, were imported directly.

    We will copy the folder from source-sites assets-directory into wp-content/uploads and will perform a mysql-replace query, so that the images will be displayed from the local wp-uploads-folder.

    Next we will use the plugin “Media from FTP” in order to register the images from uploads-folder to media-library.

    I will consider to use this and troubleshoot with another website-to-wp conversion-project, but you may convince me about a more easy workaround with “Fix Medai Library” than the one mentioned here 😉

    Plugin Author wowpress.host

    (@wowpresshost)

    I believe there are many acceptable and entirely correct ways to do that and yours is fine too 🙂

    My best wishes.

    Plugin Author wowpress.host

    (@wowpresshost)

    Note it as resolved.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Images in uploads not displayed in media-library’ is closed to new replies.