Support » Fixing WordPress » Images in the upload folder won’t load in media library

  • Hey everyone, hope you’re all fine.

    I’m having an annoying issue with my website this day. I have images contained in my uploads folder in the wp-content, but these images won’t display in the media libary on wordpress neither would they display on the website.
    I tried uploading a fresh image to see if it could and everything went fine. I can see the image i uploaded in the media library but not the images which formerly exist on my website.
    I did some research and i’ve already :
    – checked the upload folder file permission
    – deactivated all plugins and re-activate one after the other
    – change theme to default WordPress theme
    – add this line in the wp-config file : “define (‘UPLOADS’, ‘wp-content/’.’uploads’);”

    Nothing of the above worked. I’m completely missing and desperate.

    Please help me anyone and thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi @kloesnice,
    I’m sorry to say that unfortunately the Media library won’t recognise images within the wp-content/uploads/ folder unless they have been imported through the WordPress Admin (as this process assigns them an ID and a bunch of meta-information so WordPress knows what to do with the images.

    One option is to give this plugin a try – https://wordpress.org/plugins/add-from-server/ it is quite old, and no longer supported, but I’ve seen recent reports of it still working. It should let you select the folder(s) where you’ve got the images on the server, and import them into the media library.

    Hello @jordesign and thanks for your response

    In fact, the images situated in the uploads folder in the wp-content folder had been uploaded using the wordpress media library, that is when my website was running fine. As such, all those images have an ID and the rest of meta informations assigned by wordpress (i checked in the database and i can still see the links to those images registered).

    I recently made a manual update of wordpress and that’s when i started facing this problem of images not displaying in the media library whereas they’re found on the server and in the DB.

    Hey @kloesnice,
    Apologies for my misunderstanding – that certainly does make it a much tricker situation.
    I’ll do some searching and see what I can find.

    Hello @jordesign

    Ok thanks in advance for searching. On my part i’ve been searching the web for 03 days now, and i’ve found nothing yet.

    Hey @kloesnice,
    just replying here to apologise for not being more help – I’ve had no luck finding anything else either I’m afraid.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Images in the upload folder won’t load in media library’ is closed to new replies.