Support » Fixing WordPress » Images FTPed to Upload Folder Not Showing In Media Library

  • Resolved ardhill

    (@ardhill)



    Hi,

    I am working on a new Dev/staging site (Copy of existing site).

    I installed WP, installed the theme and plugins used the built in export facility in the live site to export my pages and posts etc to the new. Used FTP to copy all the images I have in my local back-up to the new dev site /wp-content/uploads (I don’t use date folders)

    None of the images are shown in my media library.

    I tried uploading a new image through the media library (the standard way), and it shows in the library and I can see the files in the same folder as my FTPed images. So, the media library shows the files I uploaded in the normal way (via the media library), but not the images that I FTPed.

    My posts show the images fine as they use the URL of the files. The images just aren’t showing in the media library. I tried changing computers in case there was a caching issue with my browser – no change.

    I am not using any caching plugins.

    The only thing I can think of ‘may be’…

    I am using https. The SSL cert is a Lets Encrypt one and I used this code in the .htaccess file to force https.

    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    No idea if this has anything to do with it, but I am putting it out there just in case as I have idea how the media library pulls the files in it’s display.

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Images FTPed to Upload Folder Not Showing In Media Library’ is closed to new replies.