WordPress.org

Support

Support » Plugins and Hacks » Twitter posts to Blog » [Resolved] Images from Tweets not showing

[Resolved] Images from Tweets not showing

Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Author badbreze

    @badbreze

    Contact your hoster to know if your server has “allow_url_fopen” enabled

    OK! it works perfectly now! thank you very much!

    I’m having problems yet… It has to be enabled or not? Right now is enabled and it doesn’t work 🙁

    Plugin Author badbreze

    @badbreze

    need to be enabled. i dont know how to help you, try contact your hoster asking for this problem. sorry

    I’m also getting blank twitter images in my posts. It appears that my host does not have allow_url_fopen enabled, but that they can whitelist some wordpress applications.

    How do I find the IP’s that need to be whitelisted by my host in order to show the images from twitter?

    Tanks in advance,

    Plugin Author badbreze

    @badbreze

    normaly the images are hosted on p.twimg.com but maybe there are some other servers

    thanks!
    My host turned allow_url_fopen on I deleted all posts permanently and reloaded them, but still blank images…
    Is there something else wrong maybe?

    Plugin Author badbreze

    @badbreze

    nothing in error log? the original images is aviable in wp-content/uploads?

    The images are uploaded to the uploads folder with names like: ‘bxlkyqrccaapyha.png’
    But they are 0KB and therefore empty (blank). I’m sorry if I’m bothering you, but I can’t find an error log. Where is this?

    Plugin Author badbreze

    @badbreze

    Deppends on your hoster, in my hosting i have an error_log file on the rinning script folder, eg wordpress main folder and wp-admin folder =)

    There you go:

    [22-Oct-2013 13:35:09] Loop query string \n
    [22-Oct-2013 13:35:12] PHP Warning: file_get_contents(http://pbs.twimg.com/media/BXLkyqRCcAAPYHa.png) [function.file-get-contents]: failed to open stream: Connection refused in /home/vhosts/botoboto.com/httpdocs/wp-content/plugins/twitter-posts-to-blog/functions.php on line 696
    [22-Oct-2013 13:35:16] PHP Warning: file_get_contents(http://pbs.twimg.com/media/BXG_8pbCMAAAdot.png) [function.file-get-contents]: failed to open stream: Connection refused in /home/vhosts/botoboto.com/httpdocs/wp-content/plugins/twitter-posts-to-blog/functions.php on line 696
    [22-Oct-2013 13:36:54] Loop query string \n
    [22-Oct-2013 13:36:57] PHP Warning: file_get_contents(http://pbs.twimg.com/media/BXLkyqRCcAAPYHa.png) [function.file-get-contents]: failed to open stream: Connection refused in /home/vhosts/botoboto.com/httpdocs/wp-content/plugins/twitter-posts-to-blog/functions.php on line 696
    [22-Oct-2013 13:37:00] PHP Warning: file_get_contents(http://pbs.twimg.com/media/BXG_8pbCMAAAdot.png) [function.file-get-contents]: failed to open stream: Connection refused in /home/vhosts/botoboto.com/httpdocs/wp-content/plugins/twitter-posts-to-blog/functions.php on line 696

    Plugin Author badbreze

    @badbreze

    nice, type this to your hoster and ask for a solution =D

    My host is asking if the plugin is trying to make a localhost connection. (That type of connection is not possible with my hosting or something) Because after including the IP’s on the whitelist and enabling the url_fopen it’s unfortunately still not working 🙁

    I’m kind of clueless in this… but I also came up to a possible CURL soloution? Is it possible to make the connection with the twimg.com server with CURL instead of file_get_contents?

    Plugin Author badbreze

    @badbreze

    yes, the wordpress cron system call itself when run some cronjobs, if your site is not able to make self calls try using this method:
    http://wpdailybits.com/blog/replace-wordpress-cron-with-real-cron-job/74

    =D

    ok so i made a working cron-job that succesfully gets the posts after 30 minutes. But it is still nog getting the images. Is there somewhere in the script a way to adjust the way the images are received that surpasses my hosts limitations?

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘[Resolved] Images from Tweets not showing’ is closed to new replies.
Skip to toolbar