Support » Plugin: FG Joomla to WordPress » Images: failed to open stream: Connection refused

  • Resolved airmaxi

    (@airmaxi)


    Hi Kerfred,
    i also have the problem with images not being copied.
    ([fgj2wp] Can't copy http://localhost:888/LTC257/images/Presse-wettkampf/trilang-podersdorf08-1.jpg to /Applications/MAMP/htdocs/wordpress3.4.1/wp-content/uploads/2008/12/trilang-podersdorf08-1.jpg : copy(http://localhost:888/LTC257/images/Presse-wettkampf/trilang-podersdorf08-1.jpg): failed to open stream: Connection refused)

    i checked the other related posts:

    Local environment: Mamp, php safe mode is off
    Folder and files permissions: Joomla:755 WordPress/wp-includes:777
    http added in url.

    Any help or ideas would be highly appreciated!
    Thanks!

    http://wordpress.org/extend/plugins/fg-joomla-to-wordpress/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author Kerfred

    (@kerfred)

    All seems good.
    Do you have allow_url_fopen = on in your PHP.ini ?

    sorry, forgot to post that: yes, allow_url_fopen = On is set in PHP.ini

    does in help you, if i post the PHP.ini or other files?

    Plugin Author Kerfred

    (@kerfred)

    I have seen that you use the port 888 for your Joomla site. Can you try with the standard port 80?
    And is your WordPress site on the same server as your Joomla site (on localhost)?

    both sites are on localhost, tried with port 80 in the url, same result.
    First i thought we had this in the bag, because the standard port i use to access the sites is 8888 (vs888), but with 8888 it´s a failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found
    with port 80 its the same as with 888….

    ok, got this worked out!!

    MySQL
    Host 	localhost
    Port
    8889
    
    User 	root
    Password ****

    vs

    apache2handler
    Apache Version 	Apache/2.2.22 (Unix) mod_ssl/2.2.22 OpenSSL/0.9.8r DAV/2 PHP/5.4.4
    Apache API Version 	20051115
    Server Administrator 	you@example.com
    Hostname:Port 	localhost:
    8888

    tried with port 8889 and everything workt like a charm.
    Thanks for pointing in the right direction! hope this helps with further problem-requests!
    Thanks again!

    Plugin Author Kerfred

    (@kerfred)

    Great.
    But can you explain what was the problem? I don’t follow you.
    Which ports did you use for Apache and for MySQL ?

    sorry, back again 🙁
    pictures show as imported, the files were created in the “wp-content/uploads/year/month” folders, but they are all 0kb…

    the port i use to call the sites in the browser is localhost:8888

    the port for connecting to the MySQL-Server is 8889

    To connect to the MySQL Server from your own scripts use the following connection parameters:
    Host localhost
    Port 8889
    User root
    Password ****

    (out of MAMP)

    Plugin Author Kerfred

    (@kerfred)

    If you type http://localhost:8888/LTC257/images/Presse-wettkampf/trilang-podersdorf08-1.jpg in your browser, do you get the image?

    yes, i get the picture if i call it in the browser.
    just tried to delete the subfolders in “wp-content/uploads/” and run the importer again. they are rebuilt with the 0KB files in it again…
    i checked again the “joomla/images” permissions, they are at 755

    did an all new wordpress installation and tried again, same outcome.
    image names are in “wp-content/upload/year/month” folders, but all are 0kb files.
    gonna leave it for tonight…
    at least i have the names there, so i can transfer the images manually a lot easier if it doesn´t work out.
    Anyway, thanks for your prompt help!

    one more… do you think i should try an older version of WordPress?

    Plugin Author Kerfred

    (@kerfred)

    No it should work with WordPress 3.4.2.

    Plugin Author Kerfred

    (@kerfred)

    Can you update to version 1.8.0 and tell me if your images are copied now?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Images: failed to open stream: Connection refused’ is closed to new replies.