Support » Plugin: One Click Demo Import » Images fail to import

  • Resolved corporatezen222

    (@corporatezen222)



    This plugin is amazing, execpt that none of the images get imported on my live site: https://themes.corporatezen.com/kolbydemo1

    I followed the instructions in the FAQ to “Change the default time of one AJAX call”, and to “Disable the generation of smaller images during the import”.

    These did not help, so I moved to the next step which is debugging the WordPress Importer. I know this is a separate plugin, but it seems as though its an integral part of this plugin, and I wonder if other people have had this issue with this plugin:

    Notice: wp_get_http is deprecated since version 4.4.0! Use WP_Http instead. in /home/themes25/public_html/kolbydemo1/wp-includes/functions.php on line 3838
    Failed to import Media “clouds”

    This notice appears for all my images. The import process works fine on my test server, but on live it never works. Here is my php settings for the live site:

    max_input_time = 120
    max_execution_time = 120
    upload_max_filesize = 128M
    max_input_vars = 6000
    post_max_size = 128M
    memory_limit = 768M
    zend_extension=/usr/local/php56/lib/php/extensions/ioncube.so
    zend_extension=/usr/local/php56/lib/php/extensions/ZendOptimizer.so

    I know these are not ideal, but will the import just never work on shared server environments (which use similar settings as these)? None of my images are more than a MB. Is there any help or advice you can offer?

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Contributor capuderg

    (@capuderg)

    Hi,

    The PHP settings look OK to me.

    We are using a modified unofficial WP importer 2.0 plugin code in our plugin.

    If you import the content XML file with the normal WP importer plugin, do the images fail to import as well?

    The issue might be, that you server does not allow to connect to your other server (where your images are stored). I would suggest, that you contact your hosting and ask them, if they can spot anything related to these failed request in the log files. They might have to whitelist your domain/IP.

    Take care!

    “If you import the content XML file with the normal WP importer plugin, do the images fail to import as well?”

    Yes they do. That is how I got the deprecation error.

    I have control over the server where these images are stored, as well as the images themselves. The images have 666 permissions, I know that for sure, and none are more than 5 MB, while most aren’t even a single MB.

    So you think the my server is probably not letting these images get downloaded for some reason?

    Plugin Contributor capuderg

    (@capuderg)

    Hi,

    I think that the server (the one that you want to import to) does not allow the connection to your server, where the images are hosted.

    I’m not sure, what the solution to this would be, but I think you should contact your hosting provider and ask them about this issue.

    Take care!

    PS: let me know, what they/you find out.

    You are 100% correct. When the images are hosted on a different server, the import works. You can mark this as resolved. Thank you!

    Plugin Contributor capuderg

    (@capuderg)

    Hi,

    I’m glad we found what the problem is.

    If you find out, what the problem on your importing server/image hosting server is, please share it here, so we can add it to the documentation of the plugin, since there will probably be other people with this issue.

    Thanks and take care!

    crerem

    (@crerem)

    Hi,

    I may have a similar problem. How can i test if a image hosting server is not blocking the import of the image.

    Thanks

    • This reply was modified 6 months ago by  crerem.
    Plugin Contributor capuderg

    (@capuderg)

    Hi @crerem,

    you can move the original export site to a different server/hosting and make a new export file, then try to import it.

    It could be that the receiving server is blocking the connection as well…

    Take care!

    crerem

    (@crerem)

    Hi,
    I found this article that explain the problem
    https://www.playnicetogether.com/2015/11/07/wordpress-importer-plugin-content-length-problem-solved/

    the solution was to add

    add_filter( ‘wp_http_accept_encoding’, function( $type, $url, $args ) { return array(); }, 10, 3 );

    in functions.php but it did not worked for me

    However it worked to comment these lins in wordpress_imported.php

    // if ( isset( $headers[‘content-length’] ) && $filesize != $headers[‘content-length’] ) {
    // @unlink( $upload[‘file’] );
    // return new WP_Error( ‘import_file_error’, __(‘Remote file is incorrect size’, ‘wordpress-importer’) );
    // }

    // if ( 0 == $filesize ) {
    // @unlink( $upload[‘file’] );
    // return new WP_Error( ‘import_file_error’, __(‘Zero size file downloaded’, ‘wordpress-importer’) );
    // }

    for some reason the file size of the uploaded file is 0 and wp delete it. I don;t know why is 0 but maybe someone from your team figure this out and offer a solution like the one in the blog post.

    Thanks

    Plugin Contributor capuderg

    (@capuderg)

    Hi,

    if a file size is 0, then there is something wrong. That’s not normal. I would guess, that it’s a server problem?

    What if you re-upload the images, that are reported as size 0?

    Take care!

    Plugin Contributor capuderg

    (@capuderg)

    Hi,

    actually I just remembered, that this kind of issue was already fixed in our plugin and I found the link: https://github.com/proteusthemes/WordPress-Importer/pull/2

    However, we still check, if the file size is 0 and skip importing that image…

    So, the image being size 0 is strange… don’t know, why that would happen.

    Take care!

    crerem

    (@crerem)

    hi,
    The image size is not 0, the image is accessible and can be loaded in browser.(for ex : http://demo-install.wpestate.org/wp-content/uploads/2018/04/WPEstateMourgueFile3313.jpg ) I did the export file 3 min before doing the import (so image was uploaded in Media).

    Maybe you can test the above link – and figure it out why it returns 0 in size.

    Thanks

    Plugin Contributor capuderg

    (@capuderg)

    Hmm,

    it’s not even a small image…

    I’ve saved the image, but since I’ll upload it to my hosting, the result will not be the same (because we probably don’t have the same server image compression settings).

    It would be easier to debug this with your XML. I can do that, but I can’t make any promises as to when I’ll be able to debug this for you (it might take weeks as I’m pretty swamped right now).

    I would suggest, that you try to debug this on your end, as it will be faster then waiting on me.

    Take care!

    crerem

    (@crerem)

    OK,
    Thanks , I will post here my findings.

    Plugin Contributor capuderg

    (@capuderg)

    Great!

    Let me know, what you find out.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.