Support » Fixing WordPress » Images don’t show up

  • I created a wordpress site on a private server I set up on the hard drive of my mac. Designed and populated the entire site and everything was running smoothly. When it came time to move the site to its live location – my service provider installed WordPress on the server, I uploaded my data base and files and everything appeared to be working just fine:
    http://www.StageWestIowa.com

    I got a call the next day saying that many of the images in the body of the pages were showing as broken links. After much playing – I found that the images on the live site are only visible IF I start the server on my local hard drive. If I shut that off – poof – the images don’t work.

    I’ve tried about everything I can think of – reloading all of the images, making sure that they are in the same location on the remote server as they are on the local hard drive.

    I’ve tried changing the code to the remote server settings. I’ve tried starting over with a fresh page and uploading a fresh image and still – the image does not appear on the page (in the editor it shows as a box).

    Can anyone help me. I feel pretty comfortable in WordPress but the database stuff is above me.

    Right now – I’m leaving my computer on with the server on so that if you visit the site, everything will appear to be normal.

    Thanks!
    Casey

Viewing 7 replies - 1 through 7 (of 7 total)
  • just edit the post and switch to HTML editor option, because the urls of the images will be based on your local machine. you will need to alter those urls accordingly to show up on posts.

    I’ve tried that several times. That also wouldn’t explain why, when I upload an image again, it still doesn’t appear as anything other than a box in the page editor or on the published page. This really has me puzzled… help!

    Hi there… Having the same issues. All images in the wp-content/uploads just quit showing up. No thumbnails nothing. The only way you can see them is if you go into Edit.

    Anyone else having the same issues?

    I finally fixed the issue – but only after deleting my entire database and site, and then reinstalling WordPress and reloading the datebase.

    Hi,

    Also check with these options;

    – Upgrade your wordpress to the latest version.
    – Disable all the plugins
    – Assign 755 recursive permissions to wp-content folder.
    – Add this code in htaccess:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Thanks,

    Shane G.

    Hi all.
    got the same issue.
    Need help.

    How do you do that:
    – Assign 755 recursive permissions to wp-content folder.
    – Add this code in htaccess:

    Thanks

    Gaelle

    I have the same issue and have done what you suggested, but it still isn’t working.

    Other ideas?

    Thanks, Eva

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Images don’t show up’ is closed to new replies.