Support » Fixing WordPress » Images don't show in post in version 4.2.2

  • Uploaded image thumbnails have not displayed in my media library since April 15, 2015. The image is perfectly visible when you click on “edit”, but back in the Media Library, the thumbnail displays as a broken link.

    When I try to insert the image into a post, same thing is displayed…a broken link place holder.

    I’ve been scouring the internet for 2 weeks, lots of people are having this issue, but I’m not finding any resolution. Does anyone have any insight to this? It would be greatly appreciated!

    Thanks!

Viewing 15 replies - 1 through 15 (of 23 total)
  • I may be seeing this same issue. Uploaded images are not generating thumbnails.

    Did any other plugins get updated recently? This seems like a rather big issue to be in Core.

    So, tidbit I just found is png’s work, jpg’s don’t.

    in my case it doesn’t seem to be wordpress. it’s something either with cloudflare, or my server. yet everything LOOKS fine. kbenik, please let me know if you have more information. What are you hosting on? Everything I’ve found points to a broken gd install, but from everything I can figure out, my GD install is just fine.

    @staze – I’ve done the typical disable/enable all plugins, that did not work. I’ve tried jpgs and pngs…didn’t work. I’ve seen lots of comments about people experiencing the same problem after recent WP update…unfortunately, I have not found any solutions 🙁

    weird. what OS is your server running? apache/php versions? I just updated php to 5.6.9, same thing. Apache 2.2.29. Mac OS X 10.9.5 is the host.

    It seems to have broken on/around 4/23/2015, which is pretty much exactly when 4.2 was released.

    I also tried with a vanilla install of 4.2, same thing. The issue is, I tried with a 3.9.6 install, and the same thing happens… so I’m not 100% that it’s a 4.2 issue.

    Also, are you using cloudflare?

    Trying to narrow down possible causes.

    perhaps it’s related to the size of the image. try to scale down the image size. my experience on my site if the image size too big, like 2544 x 1577 etc then it will not displayed correctly. it seems image displaying handled by the themes, not by wordpress.

    @staze – Ipower is my host. Not sure about the OS.
    @sahatmrt – I’m certain it’s not the size, as I resize everything before I upload – I wish that were the problem. I truly feel it has to do with the WP update that launched right around 4.15.2015 – that’s the last time I’ve been able to upload images.

    I can’t believe there’s not much buzz about this in the forum…

    I tried resizing… No luck. At this point, I cannot point to this being WordPress. Given everything I’ve tried, it just doesn’t look that way. I have to think it was due to the Apache 2.2.29 update, or something cloudflare changed on/around that date.

    Going to test with an older WP install (just tested with 3.9.6 and noticed it was from May). :/ will test with 4.1 maybe.

    @kbenik – oh so curious, perhaps updating the permalink could fix the problem, it seems the problem could be related to broken permalink, if you dont mind, please update the permalink.

    4.1 didn’t work either.

    BUT! I just disabled the php imagick.so plugin, and that fixed it. My coworker found mention of both GD or imagemagick being used by wordpress to do image resizes.

    Anyone happen to know if you can force one or the other? For those on shared hosting (not me), it probably won’t be possible to disable php’s imagick.so plugin.

    Recompiled imagemagick from source, nothing. Only way to get it to work is completely disable imagick.so.

    So, this isn’t WordPress it seems. But, I’m also really unsure WHAT it is. If I had to guess, I’d say something with the Apache 2.2.28/2.2.29 update. There was a similar 2.4 update recently as well… my other sites are all running a version RedHat backports fixes to, so it’s impossible to tell why they work, and why this other case doesn’t.

    If anyone finds anything else, please let us all know.

    Did find this: https://wordpress.org/support/topic/resize-failures-with-wordpress-now-using-imagick-rather-that-gd-library?replies=11

    Installing the plugin that the first user created, which forces wordpress to use GD fixes it for me…

    Now I just need to figure out what’s wrong with imagick.so.

    Finally found the root issue, though I’m still clueless as to what brought about it only showing itself when it did.

    ImageMagick was somehow compiled against libjpeg v9, and the PHP install I use includes libjpeg v7. Whenever imagick.so was called, it was throwing an error saying “Uncaught exception ‘ImagickException’ with message ‘Wrong JPEG library version: library is 70, caller expects 90”.

    The “fix” was to remove the v9 I had installed, compile v7 of libjpeg, then recompile and install ImageMagick, and imagick.so.

    Not sure that’ll help many people, but I can state this isn’t a wordpress issue (in my case). It just strangely showed up on/around the time that wordpress 4.2 shipped. =/

    Hope to have an article up on my website in the next 24 hours detailing it.

    First, thank you so much for all of this wonderful information!

    Perhaps, what happens for us may be of assistance:

    While we have shared hosting, the problem that has suddenly arisen since WordPress update 4.2.2 triggers the following errors that are defined using Broken Links plugin:

    “Response headers
    ================
    HTTP/1.1 504 Gateway Timeout
    Server: nginx
    Date: Mon, 18 May 2015 15:18:36 GMT
    Content-Type: text/html; charset=utf-8
    Transfer-Encoding: chunked
    Connection: close

    Request headers
    ================
    GET /partydomme.com/1/wp-content/uploads/2014/08/1cMssDidi-bikini.jpg?resize=232%2C508?w=585 HTTP/1.1
    User-Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0)
    Host: i0.wp.com
    Accept: */*
    Referer: http://partydomme.com
    Connection: close
    Range: bytes=0-2048

    Response HTML
    ================
    We cannot complete this request, remote data could not be fetched
    Link is broken.”

    – The image exists in the media library.

    MssDidi: does not seem related to me. I would report this issue to the Broken Links plugin maintainer in their support forum. But to me, it indicates your web server, or where ever it’s checking to see if it exists, is not responding in a timely manner (for whatever reason), which is the “504 Gateway Timeout”. You may need to speak to your shared hosting provider.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Images don't show in post in version 4.2.2’ is closed to new replies.