Support » Networking WordPress » Images don’t show after site move, upgrade

  • I have a multi-user site, moved to a new server. The server is local, accessible to the web. I was running WPMU and moved and upgraded to 3.0
    Server OS – Mac Server 10.6 (unix)
    Installed 3.0 and updated database from a backup.
    Interfacing with database fine all posts and users are there. I replaced the wp-content/blogs.dir directory from backup. Permissions on blogs.dir are 777 recursive
    Images are not showing up. Images are there in the blogs.dir and if I choose Edit Picture I see the image. If I look in Media Gallery I see the names of all the graphics but not images.
    I have tried renaming blogs.dir and uploading a new image to a blog, causing a new blogs.dir to be created. The image is there in blogs.dir but does not show up in the post, just a placeholder.

    Mod rewrite is enabled but may not be working properly as pretty permalinks are not working, only default.

    .htaccess is writeable

    Can anyone help?

Viewing 5 replies - 1 through 5 (of 5 total)
  • I’m having the same issue.

    I believe I’ve pinpointed the problem to the directory blogs.dir/#/files – the “files” directory for me is inaccessible.

    I worked around it by changing “files” to “uploads” in .htaccess, and in the site editor for upload path and Fileupload URL. This worked for my site 1 – but does not work for the rest of my sites – even if I follow the exact same procedure. A blogs.dir/#/files directory is created that is inaccessible?

    Aha!

    Look at this in ms-functions.php

    if (! is_subdomain_install() )
    		$illegal_names = array_merge($illegal_names, apply_filters( 'subdirectory_reserved_names', array( 'page', 'comments', 'blog', 'files', 'feed' ) ) );

    I have a subdiretory install. How do I get a filter to fix it? Anyone – someone?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Mod rewrite is enabled but may not be working properly as pretty permalinks are not working, only default.

    Then you need to add this to Apache:
    AllowOverride FileInfo Options

    Or, get your host to do it.

    @memitch – if your permalinks aren’t working, then yes, you have the *exact* same problem.

    I thought you stated in the other thread your permalinks *were* working. If so, then you still have a different issue.

    Thank you Andrea. We are hosting the install locally so we have access to everything.
    In apache2/httpd.conf I have changed
    AllowOverride All

    So change the All to FileInfo Options
    ?

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Is that the general one, or the one in the vhost entry for that account?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Images don’t show after site move, upgrade’ is closed to new replies.