Support » Plugin: Yoast SEO » Images Disappearing

  • Resolved steveraven

    (@steveraven)


    Hi guys,

    First off, I know all about the ‘Yoast Image bug’ from an earlier version, and I made sure that ‘Redirect attachment URLs to the attachment itself?’ was set to YES.

    So I’m guessing that the following problem won’t be anything to do with the Image Bug.

    What’s now happening is that up to a week ago on Google search console, my sitemap indexes and image indexes were working fine – images showing at something like 300 submitted and 170 indexed.

    Looking at Google search console now though, my ‘indexed images’ have dropped down to 4 or 5, but the submitted images remains the same.

    Is there a reason for this?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Can you confirm you have Yoast SEO for WordPress 8.3 and WordPress 4.9.8? Can you also confirm when this issue started occurring when you experienced a massive drop in the indexed images? Could you please attach some screenshots that further detail this issue as well as provide your Sitemap Index?

    Yoast 8.3 confirmed, as is WordPress 4.9.8.

    How do I attach screenshots in here?

    @mikes41720, I have a similar problem after September 15th.

    Can this be an explanation of the problem: https://flothemes.com/yoast-seo-bug/ ?

    • This reply was modified 9 months, 4 weeks ago by  Kamilwroc.

    Hang on, got it. (How to post screenshots that is, NOT the problem 🙂 )

    Right, the issue started around this last weekend and I initially put it down to another image bug.

    My yoast sitemap is HERE

    However I tried putting another image sitemap plugin on site, which made no difference SEE HERE

    As you can see at line number 9, the image sitemap is making no difference.

    I cannot really pull a screenshot from before this last weekend, but this is how it looks now: HERE

    …complete with all the waffle added by the extra sitemap.

    The image sitemap is being deleted later today.

    I’ve also been in the webmaster Tools Forums, and there are a few people with the same problem, so it might well be a Google problem whilst they’re arsing about getting things switched over to the new Search Console, which obviously does not work.

    Any help on this would be much appreciated.

    • This reply was modified 9 months, 4 weeks ago by  steveraven.
    Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    We’re not aware of such problems in Yoast SEO plugin 8.2. So, if you see a sudden image index drop in your Google Search Console property, we recommend you please keep monitoring your images as Google frequently updates their algorithm and which might cause the sudden image index drop.

    Sure, but it’s just so infuriating that Google can trample over anyone and take no responsibility.

    Somebody did that at my place and they’d get the sack immediately.

    Plugin Support Michael Tina

    (@mikes41720)

    Unfortunately, we’re not sure of what can be of help at this moment in time. Perhaps you may want to try deleting and re-submitting your sitemap, and see if this helps, as well as constantly monitoring for any updates on the Webmaster Tools forums.

    I’ve done that a few times, and no change.

    Looks like Google are being total arse holes at the moment.

    Plugin Support jerparx

    (@jerparx)

    There seem to be multiple online discussions regarding this issue at the moment and you’re not the only one affected. You can check them here and here. There also seems to be an issue with the old and new interfaces of GSC.

    Plugin Support amboutwe

    (@amboutwe)

    This thread has been marked as resolved due to lack of activity.

    You’re always welcome to re-open this topic. Please read this post before open a new request.

    Thanks for understanding!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Images Disappearing’ is closed to new replies.