WordPress.org

Support

Support » How-To and Troubleshooting » Images disappeared from galleries

Images disappeared from galleries

  • Elizabeth G
    Member

    @elizabeth-g

    Im very new to WordPress having previously used iWeb to create my website. Im a photographer and decided to rebuilt my site using WordPress.

    Anyway, Yesterday I noticed that every single gallery I had added to the site is now missing all of its images! Stupidly, I hadnt got round to backing up my site and although I have now done this, Im wondering if anyone knows how to figure out a)why the images have all disappeared and b) how I get them all back without having to reupload them all!

    Id really appreciate some help as I havent got a clue where to start!

    Thank you in advance.

Viewing 7 replies - 1 through 7 (of 7 total)
  • can you check them wp-content/uploads? normally all uploaded images goes there.

    if you want to change the path and using WordPress 3.5 and above. please read here

    WordPress 3.5 custom media upload path missing

    Elizabeth G
    Member

    @elizabeth-g

    Sorry to sound dim, but I havent got a clue what you are asking and what the link is going on about?

    Elizabeth G
    Member

    @elizabeth-g

    Sorry to sound dim, but I haven’t got a clue what you are asking and what the link is going on about?

    Elizabeth G
    Member

    @elizabeth-g

    forgot to mention, looks like all the images are in the uploads folder when I backed up to ftp but not on wordpress

    if pictures are still in upload folders and not showing in the WordPress site, It mean the link (url) point to those images are wrong somewhere in the setting of wordpress.

    How do you normally upload the pictures to WordPress? from media upload or customs field from Post?

    if you you upload from WordPress media upload and not showing, possible problem is wrong saving path.

    if you upload from post, the slug (unquie name) of the image fields is changed and not retrieving images.

    could you get me the link of the website? then I can check the image url.

    Elizabeth G
    Member

    @elizabeth-g

    I normally upload my images to my site via galleries option – ie: add new gallery then go to my folder on my mac and upload a host of images. From that gallery, I add the gallery shortcode to my pages/blog.

    However, when I open the “gallery” Ive supposedly uploaded on the backend, the gallery page shows no images have been uploaded.

    Does that make sense?

    Whats strange is that it was all working fine originally and now it almost appears like they have all disappeared from back and front end of the wordpress site

    There are so many matters to think about it.
    Is the plugin out dated while you upgraded WordPress?
    or is the plugin updated and some setting changes?
    or did you recently install new plugin for other purpose and it might clash each other.

    can you still upload from back end and see the uploaded images in back end? don’t worry about front end.

    If you can still see the recently uploaded images in back end. that mean front end isn’t retrieving the images as before.

    If you can’t see the just uploaded image in backend or can’t even upload the images. then the back end code is something wrong.

    If someone developed that website for you. pls contact them. If you use free template, pls contact the group who created that template and ask for help or check in their support section whether have same problem like you.

    If they the theme doesn’t have no problem at all, there might be some changes in your WordPress setting or code.

    This is as far as I can think off.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Images disappeared from galleries’ is closed to new replies.