• Resolved caveflyer

    (@caveflyer)


    [Password for the page is: 1z ]

    I have many wordpress blog entries on my website with mosaic galleries, and they all work fine.

    Today I tried to create a new blog post and created a gallery, but it and all the images on the new post won’t show up. The new post and all the old ones are, of course, on the same hosting server. I’ve cleared cache on my browser and cleared cache on my hosting site. I enable ‘Speed up image load times’ and they don’t show, but I unclick it and they show up. I’ve tried it with multiple browsers. I’ve uninstalled JetPack and reinstalled. I’ve deleted and reloaded images. This has me puzzled.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Bruce (a11n)

    (@bruceallen)

    Happiness Engineer

    Hi @caveflyer

    Your Jetpack connection looks great, so that’s good there. How are you creating the mosaic galleries? Do you use the Tiled Galleries Block, or are you using the Classic Editor plugin or the Classic block?

    If you create another new blog post, do you have the same problem?

    Thread Starter caveflyer

    (@caveflyer)

    I’m using the Classic editor plug-in (which, again, I’ve used for 100% of the other blog posts for this site). And I created the gallery the same way I’ve created all the other galleries on this site, with just the ‘Create Gallery’ under ‘Add Media’. Sorry to sound like a broken record, but it’s just awful strange. Normally, disabling the ‘Speed up image load times’ would cause ALL the galleries on all my other posts to change from mosaic to standard format, but they now don’t do that. Only the posts I’ve created in the last couple of days seems to be affected by enabling/disabling ‘Speed up image load times’. And in a negative fashion as described. So weird.

    The test-2 page I appended to this thread *IS* a new blog post. My original blog post that was having these issues, I knew better than to fool around with it, so I created ‘test-2’ to see if the problem replicates… and it did. So, it’s got to be systemic *except* for the fact that is doesn’t affect the older posts. I’m truly stumped.

    I do have to say, that the problem might be related to my hosting site. I say that because all my old posts were created before I moved to a new hosting site. Since the move, this is the first blog post I’ve created. I used UpdraftMigrator to move the site, and it seemed to be 100% successful. When I started having this problem, I did try purging the worldwide cache, and I tried fiddling around with Hotlink Protection (turning things on or off) but I’m not sure that accomplished anything. (And if it were something with my hosting, then wouldn’t it affect ALL my posts, not just the new ones?)

    Color me stumped.

    Thread Starter caveflyer

    (@caveflyer)

    Interestingly…. if I embed a single photo, then I get a source line such as this:

    https://i0.wp.com/www.robertlaird.com/blog/wp-content/uploads/2022/07/20220710_082929.jpg

    and if I plug that into a browser, I get the error message:

    “We cannot complete this request, remote data could not be fetched”

    If I remove the “io.wp.com” then it displays the image. This makes me think it’s the Hotlink Protection, so I’ll fool around with that some more.

    Thread Starter caveflyer

    (@caveflyer)

    Another discovery… apparently, when migrating a wordpress site to another host, a lot of these methods will rewrite the .htaccess file. The behavior that seems to affect new blog posts could certainly be explained if the .htaccess files have been modified/added/changed somehow. Unfortunately, I’m not up to speed enough on the .htaccess instructions to know what or what not to change. As mentioned above, I did uninstall JetPack and reinstall it, so that process supposedly would alter the .htaccess in an appropriate way (for its own block), but may not do any good with respect to blocks created by other processes. So, I’m stuck right now with trying to figure out 1) if the culprit truly is .htaccess, and 2) if it is, then what changes were effected that cause this issue…

    Plugin Support Mehdi (a11n)

    (@muffinpeace)

    Hi @caveflyer

    Thanks for providing those explanations! I don’t suspect that the .htaccess is the culprit involved here; however, the error message you’ve encountered when browsing the image through the CDN (We cannot complete this request, remote data could not be fetched) definitely points to the Hotlink Protection, so I’d suggest turning it off, and then disabling re-enabling the Site Accelerator for images.

    The .htaccess theory is still a possibility since it’s possible to protect images and enforce Hotlink protection through some htaccess rules; however, that’s worth testing using the WordPress default .htaccess file instead of the final file after migration.

    Let us know what you find.

    Thread Starter caveflyer

    (@caveflyer)

    Thanks very much for the reply and suggestions. I have played with Hotlink Protection extensively (not that there’s that much to it), but it doesn’t seem to have any effect. By default, Hotlink Protection is *not* on. There is no entry in the “Block direct access for the following extensions(Comma-separated)”, so no files are blocked. In the “Whitelisted Domains” section (which previously was blank), I’ve added “robertlaird.com, http://www.robertlaird.com, i0.wp.com, wp.com” but that had no effect. The only other two options are a checkbox for “Allow Direct Requests” — the default is not-checked, but I’ve checked it and seen no effect… and, “Redirect Block Requests (Optional)” for which the default is blank, but I’ve tried both “false” and “true” in that field, to no effect.

    To be clear, no matter what I tried with Hotlink Protection, it was and is still true that if I deactivate “Speed up image load times” in JetPack, the images will then show up… if it is activated, they will *not* show up. So, nothing I’ve done with Hotlink Protection seems to work.

    (I do have a correction from my original post. This issue *does* affect all the other pages on the WordPress blog posts, not just my test-2 post, and not just the new posts… it affects the old posts as well.)

    I’m really not sure where to go at this point.

    Plugin Support Mehdi (a11n)

    (@muffinpeace)

    Hi @caveflyer

    Thanks for your patience and consistency in working with us to solve this. Did you, by any chance, try to test this with a default theme such as Twenty Twenty-Two, and by disabling all your plugins and only keeping Jetpack active? Since Hotlink Protection is already disabled, and no .htaccess rule is blocking us, I suspect a theme or plugin conflict.

    If that persists despite that, please reach out to us here instead so we can investigate this further.

    Don’t forget to mention a link to this forum thread 🙂

    Thread Starter caveflyer

    (@caveflyer)

    Thanks. I did try to deactivate most (but not all) of my plug-in’s at one point. But I haven’t tried an alternate theme. Since I just published the blog post I’d been working on (using a work-around for the gallery look), I’m going to sit on this for a few days before I try the theme change (and deactivate ALL my plug-in’s, one at a time). If none of that works, I’ll be back in touch soon. Thanks, Mehdi… very much appreciated!

    Plugin Support lastsplash (a11n)

    (@lastsplash)

    Sounds good. Let us know what you find out and we can take another look if you continue to have issues.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Images “break” when I enable ‘Speed up image load times’ on new blog posts’ is closed to new replies.