Support » Plugin: Smush - Lazy Load Images, Optimize & Compress Images » Images are not getting smushed

  • Resolved pargavi412

    (@pargavi412)


    Hi! Im using the free version and wanted to clarify something before I move to the pro one. When uploading images to the media library, the images get smushed automatically. For example, a 450 kb image has been smushed to over 97-100 kb. But recently, like around a month or so, any image that has been uploaded to the media library, say whether it is 540 kb or less than 540 kb, the images do not get smushed that properly. The result is a 540 kb image is smushed to only 520 kb or a 170 kb image is smushed to only 160 kb. What is this and why does it happen? Would be great if sorted out. Is there any limit in the free version? Or does going pro solve this? This has to be done for seo optimisation! Kindly help.

    • This topic was modified 2 months, 1 week ago by pargavi412. Reason: Didn't complete my question
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @pargavi412

    I hope you’re well today and thank you for your question!

    There is no that kind of limit at all. The end-result of compression depends mostly on the “input image” – its format and actually its content as some images can be compressed way more efficiently than others.

    There’s no difference also between Pro and free version if it comes to default lossless compression that both plugins use. The Pro version provides also optional lossy compression but that’s another option and it doesn’t relate to the issue that you reported here.

    I’d say then that there are two most likely reasons for this behavior:

    – either the images that you are recently uploading “happen” to be already well optimized before uploading
    – or there’s actually some kind of conflict that does really break optimization process.

    Are you using any other plugins that are possibly meant to optimize images (such as e.g. WP Optimize or some image optimization enabled in caching plugin or theme)?

    Could you also try this:
    – disable automatic optimization for a moment
    – upload an image while it’s disabled
    – then bulk-smush images
    – then check how much this particular image has been optimized and also if there were any errors/warnings during smuching process

    You can enable automatic optimization back afterwards but give it a try, please, and let us know about results.

    Best regards,
    Adam

    Thread Starter pargavi412

    (@pargavi412)

    Hey Adam. Thanks for the reply. I will try all these that you have mentioned as there are other caching plugins with auto optimisation. Will get back to you tomorrow to update the result.

    Plugin Support Patrick Cohen – WPMU DEV Support

    (@wpmudevsupport16)

    Hi there @pargavi412

    How did the testing go?

    Please do let us know if you have managed to resolve your issue, or if you still need help with this.

    Cheers!
    Patrick

    Plugin Support Patrick – WPMU DEV Support

    (@wpmudevsupport12)

    Hi @pargavi412

    I hope you are doing well and safe!

    We haven’t heard from you in a while, I’ll mark this thread as resolved.

    Feel free to let us know if you have any additional question or problem.

    Best Regards
    Patrick Freitas

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.