Support » Plugin: WP Original Media Path » Images are not displaying on website and not showing thumbnails in medialibrary

  • Resolved impresseo

    (@impresseo)


    Проблема була в тому, що при виведенні медіафайлів у піддомен mediafiles.domain.com.ua не відображалися іконки зображень в медіабібліотеці і на вебсайті. При цьому зображення нормально завантажувалися і зберігалися в теці піддомену.
    Жодні налаштування DNS чи через .htaccess не допомогли. Вирішення проблеми – змінити налаштування теки піддомену mediafiles.domain.com.ua на rwx r-x r-x. І все працює. Тому що через плаґін основний домен бачить піддомен, як ТЕКУ, проте без вручну розширених прав доступу до цієї “теки” не може варіативно обробляти зображення (адже при завантаженні одразу можуть створюватися декілька різнорозмірних копій зображення).
    ENGLISH: The problem was that when working through plugin with subdomain mediafiles.domain.com, then thumbnails didn’t appear in medialibrary and images didn’t show up on website. Although, the images loaded correctly and I could open them in medialibrary for example for editing. The DNS or .htaccess settings change didn’t help at all. The solution was so obvious and simple – extend permission rights on subdomain folder itself (mediafiles.domain.com) manually to rwx r-x r-x and recoursively the included folders. The files I set rw- r– r– . Then everything have started to work properly.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Images are not displaying on website and not showing thumbnails in medialibrary’ is closed to new replies.