WordPress.org

Support

Support » Plugins and Hacks » WP Original Media Path » Images are giving 404 error.

Images are giving 404 error.

Viewing 15 replies - 1 through 15 (of 25 total)
  • Plugin Author RVOLA

    @rvola

    Hello Ananddesigner,

    the easiest way to understand the error 404 is:
    – Define the domain or subdomain for images.
    – Verify that the domain or subdomain are active in the right place.
    – Define the exact location of the folder for uploads
    – Verify that the path is followed.

    To verify and understand the error, simply move the media library and watch the permalink of a picture.
    By analyzing this address, you normally find out what is wrong.

    You can also give me the link of your website in order to solve the problem together.

    sir,it is necessary? i am using folder for images it should be sub domain or domain rather than a simple folder.

    Plugin Author RVOLA

    @rvola

    Not the subdomain is not required.

    For example my website is http://siteweb.com

    By default the images folder of WordPress expected to be here:
    http://siteweb.com/wp-content/uploads

    I decided to rename my file uploads in ‘my_images’ directly to the root of the website, which gives:
    http://siteweb.com/my_images/

    With the plugin WP Original Media Path, you must fill out 1 field options:
    my_images
    and the second field:
    http://siteweb.com/my_images

    Be careful with slash unnecessary.

    Yet another example to understand:
    I want to rename the file uploads in ‘media_thumb’ and put it in my folder in my theme ‘twentyten’

    The first field looks like this:
    wp-content/themes/twentyten/media_thumb
    the second looks like this:
    http://siteweb.com/wp-content/themes/twentyten/media_thumb

    i have changed my images path…
    http://mysite.com/library/
    but when i uploaded a images and check them in browser it is giving me 404 error..and when i checked in my ftp that images was there.

    Plugin Author RVOLA

    @rvola

    OK
    the first field settings page media must be:
    librairy

    and the second:
    http://mysite.com/librairy

    Normally it should work, to check if the same image is 404, the inspector look into the URL problem

    yes sir i am doing this..but it is not working..image path has been changed and image is also in my this folder..i can see this image..but it is not opening in browser..it is giving 404 error

    Plugin Author RVOLA

    @rvola

    it must necessarily have a problem with that slash behind.

    You have a sample URL?

    in first column : library
    in second column : http://mywebsite.org/library/

    Plugin Author RVOLA

    @rvola

    Do you put other conditions in the wp-config.php file that could taint the URL changes?

    Did you try to check the WP_DEBUG = true
    to understand the problem?

    sorry..i do not know about this..what is this..

    Plugin Author RVOLA

    @rvola

    some reading to identify problems servers;)
    http://codex.wordpress.org/Debugging_in_WordPress

    can you tell me.. i am feeling strange now my new image folder contain a new htaccess files..i dont know how is this file here and that htaccess file contain this text:

    Order deny,allow
    Deny from all
    <Files ~ “^[0-9A-Za-z]+\.(jpeg|gif|png)$”>
    Allow from all
    </Files>

    Plugin Author RVOLA

    @rvola

    Ah!
    That’s the problem …

    try to rename the file. back.htaccess htaccess and verify a URLd’image

    ok now i am understand..i am using wpcf captcha..thats why..this file is here…

    Plugin Author RVOLA

    @rvola

    I do not know. Now it works?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Images are giving 404 error.’ is closed to new replies.
Skip to toolbar