Support » Fixing WordPress » Images are changed to -This image was hotlinked-

  • Since yesterday I see ugly pictures instead of pictures from Mediathek.
    It is only by new pics, older will be shown.
    On Plesk I deactivated avoiding hotlinking.

    Only I seem to see this, in incognito browser I see it normally.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Your site looks OK to me.

    I wrote: Only I seem to see this, in incognito browser I see it normally.

    And hope that is only here, but why suddenly only I see this, and only last uploaded pictures? in sidebar

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Again, I don’t see that. Your browser may have cached those images.

    to be cached it had first to be there, which is a failure as all pictures are from tha same domain 🙁
    I deleted cookies, I logged out, same result.
    Have you ever seen such pictures like this, waht is causing them?

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    This is a thing from your hot-link blocker. Another person reported something similar in the lat couple of weeks. As this is due to something in Plesk, *not WordPress*, please contact Plesk support about it.

    I took this plesk “prevention” away and still the same 🙁 OK I will ask there

    Hi,

    I have the same issue with my website and I’m also using plesk.
    Do you found a solution for this problem ?

    Thanks.

    Yes I have 🙂
    There is new “feature” in Plesk which is unwanted for me.
    When You go to WordPress too (last point in menu)
    there is a security check for domain. It is green when all is ok.
    I think noe the 2nd point there is about secure pictures to not be hotlinked from other sites. But it block aldo pictures fro my site 🙁
    Uncheck this and apply.
    But fist in few hours it worked again properly.
    Also check maybe php version, change to newer, it often makes issues.
    Good luck!

    Hi,

    had the same problem.
    Plesks security feature bring this issue out to light, correct. But the root cause is indeed that images are used that aren’t stored under the real domain name.

    had a clients site in testx.xyz.com . Used Plesks clone feature to clone it to the live xyz.com .
    Resulted in some images being replaced by “This image was hotlinked”.
    Checked, and some images on xyz.com were indeed still being loaded from testx.xyz.com – which is technically a different domain, hence the warning.

    logged into WP on xyz.com , loaded better search and replace plugin, and replaces all instances of testx.xyz.com with just xyz.com
    > issue solved.

    IMHO better to solve the root cause then to turn off a security feature that alerts you to the issue.

    I was affected by this problem after a Plesk security update. I pull images from a sub-domain within my tld and still have the image with the message “this image was hotlinked”.

    If you have access to the file directory wher your images are pulled from, you can place a .htaccess-file to allow hotlinked images. This worked fo me perfectly and with no effort. For this, read the following instructions here

    good luck
    Dominik

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.