Support » Plugin: Max Mega Menu » Images and widgets not showing in menu

  • Resolved palombaro

    (@palombaro)


    Hello,
    I’d like to display images and slides (using smart slider plugin) in my main menu. I tried adding them both via widget and shortcode, but the submenu won’t show anything. You can check under “I Librosi – Artigianato Fantasy” in my menu bar: all it displays is a blank window. Is there a fix?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author megamenu

    (@megamenu)

    Hi palom,

    Thanks for posting a link.

    In the console I see an error:

    https://screencast.com/t/ylyWlgk5

    Can you make sure there is only one instance of a slider on any one page and see if that helps?

    Regards,
    Tom

    Hello Mega, thanks for replying!
    I did disable smartslider but, as I tought, nothing changes. I tried other plugins (img plugin, author plugin, recent posts plugin) other than smartslider, but none of them gets displayed in the submenu. I tried looking for some “display: none” or “visibility: hidden” suspects both in the page source code and in my theme’s php, but I couldn’t identify the problem…

    Plugin Author megamenu

    (@megamenu)

    Hi Palom,

    Ok, please could you add a standard image widget to one of the sub menus so I can investigate further? Please post a screenshot of the settings in the backend (in the mega menu builder, where you have added the widget) and where it should be appearing in the front end.

    Regards,
    Tom

    Hey Mega,
    There was an img widget in “Artigianato Fantasy”‘s sub menu already and it’s still there, despite it not showing up. It’s strange but I can’t even find it in the page’s source code. Anyway, here’s the screenshots.
    Settings:
    1
    2
    3
    4
    5
    Where it should be appearing:
    6

    Plugin Author megamenu

    (@megamenu)

    Hi Palom,

    Thats helpful thanks. If you go to Appearance > Menus, hover over the Artigianato Fantasy and click the blue mega menu button. In the “Mega Menu” tab, what do you have the Sub Menu Display Mode set as?

    Regards,
    Tom

    Hello Mega,
    thank you very much! I had it on flyout menu and it worked when I changed it to standard. I had done that already on the submenu but I didn’t know that megamenus do not work on submenus! Everything is fine now, except smartslider still doesn’t work, but I don’t really care.
    Thanks again!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.