WordPress.org

Forums

Ridizain
[resolved] Images (6 posts)

  1. rainejones
    Member
    Posted 2 years ago #

    Hi Zulf,

    As discussed in my other thread, the images on the theme, have changed from rectangles to ovals.

    I am not sure what I have done, I am not even sure where to look to see how this has happened, could it be possible that it is a plugin that has caused this?

    http://www.qanurserymagazine.co.uk

    many thanks for your help

    Lorraine

  2. Brian Harris
    Member
    Theme Author

    Posted 2 years ago #

    Hello Lorraine,

    Just had a look at the site and I can see where the problem is coming from but I'm not sure how the code was added. The file in question is clean_style.css and @line 26 onwards is the code below...

    .wp-post-image {
        display: block;
        margin: 1em auto;
        background-size: cover;
        background-repeat: no-repeat;
        background-position: center center;
        border-radius: 99em;
        border: 5px solid rgb(238, 238, 238);
        box-shadow: 0px 3px 2px rgba(0, 0, 0, 0.3);
    }

    There are two elements at play in that code which are the cause of the issues you are facing.

    The first one is where the images are pulled out of place i.e overlapping the read more button in the sidebar - that bit of the code is the display: block; needs to be changed to display: inline;

    The second one which is responsible for the oval shape is border-radius: 99em; - removing that will revert the images back their rectangular/square shape or you can adjust the value to what suits you if you still need to keep the oval/circular shape. I would personally use something like 50% 0r 500px instead of 99em as the value.

    You may also need to apply a height to the images so that you get an even circular shape that they currently are.

    Hope that helps in resolving the issue - let me know if there's anything else I can help with.

    Regards,
    Zulf

  3. rainejones
    Member
    Posted 2 years ago #

    Hi Zulf,

    I'm really sorry about this, but I'm struggling to find a file called clean_style.css, I'm certain I'm looking in wrong place, I've done a search in my ftp and it brings nothing up, so I have had a look through the editor in wordpress and can't find the file in there either. I've just had a look at it from the show source, and can see clean_style.css, so can see what you are saying, however, as I said I'm new to this, and not sure how to find the correct file to sort this.

    I'm very confused now, we have another website that I have used this same template on, the images on this one are absolutely fine, I have just had a look at the source files on that site, and they don't even have a clean_style.css

    http://www.electrofacts.co.uk

    Please can you help?

    Thanks

    Lorraine

  4. Brian Harris
    Member
    Theme Author

    Posted 2 years ago #

    I'll be more than happy to help you figure it out.

    Could that be from a custom styles plugin?

    Just had a quick peek at the site and seems like you have it sorted now?

  5. rainejones
    Member
    Posted 2 years ago #

    Hello Zulf,

    I have sorted it, it was a plugin as I suspected, I have deactivated and removed it and it has solved the problem.

    Thanks for all your help.

  6. Brian Harris
    Member
    Theme Author

    Posted 2 years ago #

    Cool.

    Marking thread as resolved but feel free to raise a new one if there are any other issues you need assistance with.

    Regards,
    Zulf

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic