Support » Fixing WordPress » Image/media flash uploader still not working?!

  • Resolved edfladung


    The image/media flash uploader buttons aren’t showing. you can see what the interface looks like here. I’m on a mac, 10.5.6, flash player 9,0,124,0. WP 2.7 This problem persists through both Safari and Firefox, across multiple installs of WP both remote and local (so it’s not that I’m missing files).

    I’ve tried everything in the sticky topic: Image/Media Uploader problems? and nothing is working.

    Here’s my working list of things I’ve done:

    • deinstalled flash player 10
    • installed flash player 9
    • cleared cache twice
    • restarted browser
    • tested “add image/media flash upload” = still can’t see them
    • disabled all plugins
    • cleared cache
    • restarted browser
    • tested “add image/media flash upload” = still can’t see them

    Does anyone have any advice at all?

Viewing 10 replies - 1 through 10 (of 10 total)
  • bump?

    I know this isn’t helpful to you but I have found the whole manner in which WordPress handles Image/Media to be completely borked. I have never been able to upload images, either using the browser or Flash methods. Even when I upload images manually via FTP they never appear in the Media Library. I have tried all the suggested trouble-shooting options and still no ‘luck’. I have been close to dumping WordPress because of these problems. It certainly makes everything a lot harder. I had hoped 2.7 would solve the problems I was having, but, I’m afraid not.

    So, no solutions I’m afraid, but I share similar frustrations.

    edfladung – I did some more digging/playing around with this. After searching the forums, etc., I changed the permissions of upload directory of the images to 777. I was then able to use the browser upload function and the image appeared in the Media Library. However, I am not prepared to have that directory permanently on 777. The risk is too high. See for example The same article suggests that “Its usually pretty easy to have the enhanced features provided by the impressive WordPress plugins available, without having to put yourself at risk.” Hmmm… Looks like I have more digging to do.

    i have no problem using the browser uploader. my problem is strcitly not being able to see or use the flash uploader. my problem is not a permissions problem. it’s a WP + Flash problem.

    I found out what my problem was. I had updated to WP 2.7 using WP automatic upgrade. I downloaded a fresh 2.7, uploaded it to my server and everything worked perfectly fine.

    This is still a problem, which I’m having right now.

    In the past few years I’ve been using various installations of WordPress, I’ve yet to see the Media uploader work.

    I totally agree with KiwiTinshed; the whole manner in which WordPress handles Image/Media to be completely borked…

    I ended up moving my blog to a new host (Downtown Host) and now all the image/media processes are working as designed. It was one of the reasons for moving to new, and WordPress friendly, host – I just got so frustrated with it not working on my old host. Of course I can’t tell what is different on the new host that makes it all work now, but at least it is working. But I still remember that sense of frustration when it wasn’t working…..

    I have three WP blogs installed at the same hosts. The latest install is the problematic one. I click in image, video and so on to upload an image and nothing happens. I click on *Add Categories and nothing happens. Menu options to upload images work as do the add new categories menu options.

    I’m now in the process of copying over new files. That is complicated because my web host has installed FTP file throttling making it impossible to upload groups of files usually greater than 6 but it has stopped at two.

    I have the latest Bad Behavior plugin. I noticed it blocking requests from the image editor indicating my header had something unexpected in it. Disabling bad behavior did not fix the problem. I have the latest flash player, 10. The uploader works in my other WP installs so the browser on my machine isn’t the issue. Also tried multiple computers.

    The video icon is now missing and the image alt words are no displayed. That’s new since I started trying to update files. With my web provider complicating my upload life I may never get a clean upload.

    Ever get this fixed?

    I’m still dealing with it, after at least 6 months.

    Uhh… not resolved.

    I use automatic upgrade just fine on the other domain/installation. So that alone is not the cause.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Image/media flash uploader still not working?!’ is closed to new replies.