Support » Fixing WordPress » Image vanished since 3.5 update

Viewing 15 replies - 16 through 30 (of 35 total)
  • Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    I think you just take the URL from that PasteBin’d page

    http://pastebin.com/z8S3HW5C there you go, ive set it to expire in 1 hour.

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    So that’s the Child Theme header.php, which is different to the parent theme’s header.php file because it’s missing an image? If so, can you copy the parent theme’s header.php file and paste it over your Child Theme header.php file?

    That was my parent themes header.php, my child theme is literally just the style.css which worked before (until the update)

    My aim is basically to have my Logo sit on the top left of my site am i going about this the wrong way?

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    That sounds correct, you just need a header.php file in your Child Theme directory.

    Then, modifying your Child Theme directory header.php file, add this code just below <div class="padder">;

    <a id="logo" href="/" class="linkedImage">
     <img src="/path-to-your-image/your-image.png" alt="<?php bloginfo( 'name' ); ?> />
    </a>

    Ok i’ve done that sadly not a great outcome http://www.releasethereal.com/
    Have i placed the code in the wrong place?

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Can you replace this bit of the above;

    <a id="logo"

    with this

    <a id="logo_image"

    Then you can use CSS to style the logo to the position you want.

    No luck, for some reason its not laying over my header image its inside a white box + it has changed the rest of my site

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Hmm, something added <div id="container"> around the logo. This is causing the white box + layout change.

    Ok i’ve tried your codes again this time it has moved the menu + search bar out of position, any ideas?

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Try this CSS;

    #logo_image {
     float: left;
    }

    Sorry, can you repeat where the image should be?

    That code seemed to do the trick, now the logo needs to be raised higher do you know the CSS code for this?

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Okay, try that CSS, I think that almost gets it. It looks like your navigation would then be slightly falling-off the header section.

    That code seemed to do the trick, now the logo needs to be raised higher do you know the CSS code for this? (Excuse the last post)

    Moderator Andrew Nevins

    (@anevins)

    Forum moderator

    Try applying CSS margin styles to #logo_image

Viewing 15 replies - 16 through 30 (of 35 total)
  • The topic ‘Image vanished since 3.5 update’ is closed to new replies.