Support » Fixing WordPress » Image URLs

  • Resolved anneandkita

    (@anneandkita)


    I am having a strange issue with images. The URLs to the images do not seem to correlate to the server structure.

    For instance, this image:
    http://www.play-crafts.com/blog/wp-content/uploads/2012/10/mosaic39d91da310b15ae35e28373b7358a7e13c40fcbf.jpg

    loads fine, but does not actually exist on my server. When I navigate to that directory, that image file is not there. This is the case for a number of images that are used in my blog posts. This is problematic as I’m trying to move my blog to a new host, and all the images that don’t exist on the server aren’t copied over and I end up with missing images. This only happens with a subset of my images, others appear on the server just fine.

    I am totally baffled as to what is going on. Any help would be very appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Would like to suggest getting your hosting company on this issue.

    It’s currently being hosted by Dreamhost.

    Not sure if it matters, but there is also a drupal install on the same site.

    Looking through the uploads directory, there are no image files after October 2nd, although there’s blog posts (with working images) three times a week for the entire month. The URLs in the blogs all post to the uploads directory, but the images are not there.

    esmi

    (@esmi)


    Forum Moderator


    Check your uploads path in Settings->Media. It should be blank in most installs.

    This appears to be a case of PEBKAC. At around October 2nd, I switched from a shared server to a VPS…and I was ftping into the shared server.

    Closing this for now. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Image URLs’ is closed to new replies.