[resolved] Image uploads not working (5 posts)

  1. johnkanesmith
    Posted 6 years ago #

    Im having an issue with images that i upload and attach to posts not appearing.

    The only thing that has changed with my site has been that my web host changed my FTP passwords. I couldnt find a place in wordpress to update that info, but the files are actually being uploaded, the problem seems to be in viewing them. I can go to my ftp site and download and view them, they are complete files; however, when i visit their links i get an access forbidden error. And if i re-write over the FTP files i still get errors. Same with if i try to upload to another folder on the FTP.

    (ex: http://www.johnkanesmith.com/blog/wp-content/uploads/2010/04/tomato-billboard2.jpg)

    Im hoping this is a permissions thing i overlooked. Can someone help me?

  2. Shane G.
    Posted 6 years ago #


    Check with these options:

    - Assign 755 recursive permissions to wp-content folder with the help of your web hosting service provider.
    - Add this code in htaccess of your blog/site:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off


    Shane G.

  3. johnkanesmith
    Posted 6 years ago #

    great... i worked so hard to get things the way i wanted them. dont wanna mess with anything and chance screwing something up.

    what could have caused this? was it the web host? if so i have a bone to pick with them...

    i may just have to host the images in another file, manually, and insert them by their url's.

  4. esmi
    Forum Moderator
    Posted 6 years ago #

    I'd ask your host to reset the folder permissions for you as they seem to have caused this in the first place. Ask them to change the permissions on the wp-content directory to 766 initially. If you still have problems, they'll need to try 767 or 777. Once your uploads are working, they can then change the permissions on wp-content back to 755 again and you can check that everything still works OK.

  5. johnkanesmith
    Posted 6 years ago #

    thanks esmi! thats all i had to do... gave a call and they reset all the permissions on their end to 755. done deal. thanks again.

Topic Closed

This topic has been closed to new replies.

About this Topic