[resolved] Image uploads broken after update (12 posts)

  1. Maxaud
    Posted 5 years ago #

    I went from WordPress MU 2.9.2 to WordPress 3.0 Multisite and I noticed all the images in my media section of wordpress are broken links.

    I have a different installation that is 3.0.1 and not only are all the images broken but the media uploader stopped working.

    I tried following the advice of many threads out there to fix it with no luck.

    Is this a problem many people are having?
    A lot of the ones I see are related to regular WordPress and refer to the /uploads directory which the multisite doesn't use.

  2. Maxaud
    Posted 5 years ago #

    I found that "Safe Mode" was turned on for the IP address in question causing the upload errors.

    I still have all the images in the backend broken since the upgrade to 3.0 though.

  3. Need more details. :) Site url, if possible, a location of a broken image, and of one that works (if one does).

  4. Maxaud
    Posted 5 years ago #

    Thanks Andrea,

    Link to Network:
    (Note: not the same install as LocalCityBlogs.com like the website would suggest. Both are having the same issue though.)

    Link to working Image:
    w/ rewrite:
    w/o rewrite:

    Link to non working image:
    w/ rewrite:
    w/o rewrite:


    [Large code excerpt removed by moderator. Per forum rules, please use the pastebin for all large code excerpts. It works better anyway.]


    [Large code excerpt removed by moderator. Per forum rules, please use the pastebin for all large code excerpts. It works better anyway.]

  5. Maxaud
    Posted 5 years ago #

    One thing I'm noticing is that the broken image are going to Lenderama.com
    (In FF and Chrome they show broken but in IE they forward to the Lenderama domain...)
    where they were imported from a blog there.
    Maybe they didn't import correctly?

  6. Maxaud
    Posted 5 years ago #

    hmm, so re-uploading the images seems to work. Very odd.

  7. Could've been an IE cache issue? The non-working image link above worked for me.

  8. nemdil
    Posted 5 years ago #

    This is a big problem, because the pictures are uploaded to "/wp-content/upload" folder for the main site, but in the sub-sites the pictures are uploaded in "/wp-content/blogs.dir", which make them don't show up in the posts when i upload the picture using media uploaded and i select picture in category,

    however, I'm using a plug-in called "Viva-ThumbZoom" showing the main picture which come with the plug-in is installed in a location which it does not exist in my website's directory : http://nemdil.info/fouzi/wp-content/uploads/cat1_NpAdvMainFea.jpg

    but the picture i uploaded goes here : http://nemdil.info/fouzi/files/2010/08/NNN.jpg

    but fouzi folder dont exist in my website ???

    main site : http://nemdil.info
    sub site : http://nemdil.info/fouzi

    Thank you

  9. It;s a problem for plugins that aren't built with the network in mind, yes. they need to check if multisite is active and figure out the upload path accordingly. Yes, others plugins do that just fine. ;)

    Those upload folders are virtuall and rewritten via the htaccess file.

    But, like I said - plugin author needs to check for it.

  10. You already posted in a separate thread.... it's the plugin.

  11. Maxaud
    Posted 5 years ago #

    I'm thinking the image is working now because I re-uploaded it.

    I'm thinking it didn't bring the images over completely when it was imported and that was done around the same time as the update so I assumed it was due to that.

  12. Oh yeah, if you were importing at the time... that's different, and that'll do it. :D

Topic Closed

This topic has been closed to new replies.

About this Topic