Support » Fixing WordPress » image uploader, still! tried all fixes

  • So, i’m having the same problems as everyone else.

    At first I got the http error when attempting to upload images. I went thru Otto42’s fixes, reuploaded and replaced all files, restarted my browser, made an .htaccess file with given code, don’t use badbusiness, etc etc. I use Firefox and I’m hosted on Laughing Squid. (Another thing, I just switched hosting, and thought I had backed up but all my posts are gone. I can live with that, tho.)

    After I created the htaccess file, my error went from saying http error to “The uploaded file could not be moved to /var/www/vhosts/ 102”

    I’ve gone through all the various threads and tried unticking the months/dates folders box, typing or not typing the full path to the upload folder, and anything else I understood how to do.
    I only know enough code to get myself into trouble, it seems, so I hope that someone can help me out or that a new release of 2.5 will fix this as images are pretty much the only thing I put on my blog!


Viewing 13 replies - 1 through 13 (of 13 total)
  • Join the gang 🙂 I would love to see a solution for this.

    yeah-images seem like a pretty important part to get ironed out before you release a new version!

    anyway- an update-
    i changed my permissions on the upload folder to rwx rwx rwx, and then it allowed me upload. however there is no image- a small grey box shows up.

    there is no image preview anywhere, so now i’m having a totally differnt problem! help, wordpress developers!

    I am have similar issues however the buttons for the upload are not working.
    Only one is showing there is an example here:

    Tried to add a link and that has not even worked.

    I have no idea whats happening.

    Thanks in advance

    Edit: the no flas plugin post worked, horray.

    I get an error message “Specified file failed upload test“. It ends up in the gallery but I can’t access it. Since I’m new to this and started with version 2.5 I was wondering if version 2.3 worked any better.

    Here’s what I’m seeing. The images upload OK and the system creates smaller versions of 150×150 and 300×200 in my uploads/2008/04 folder. The media library shows the filename (minus extension) but no image. When I mouseover where the image is supposed to be, I see the pointer finger but do not see a menu. However, if I manually enter the URL into the post the image will display in the post just fine.

    I also noticed that when I look at the media library page, the “Show” button doesn’t work. Looking at the page source, I found this.

    <a class='toggle describe-toggle-on' href='#'>Show</a>

    I think whatever is causing the problem is putting a “#” for the URL of the image which is why we’re not able to see it on the screen or “show” it. Viewing the meta data in the database appears to be the correct path to the image (copying and pasting it into a browser gives the the correct image).

    I hope this helps someone way smarter than me figure out what’s going on.



    I’m having the same experience as bowerbox… “The uploaded file could not be moved to….etc. followed by “79”.

    I got this message after creating the .htaccess file and changing the directory target from “uploads” to “wp-content”. The “wp-content” directory is writable, but I can’t upload an image.

    Here’s what I finally had to do. Had to go into my php-admin and make sure to tick read, write, etc… until it showed 777 in the permissions box. Then I had to make a folder called “uploads” in my wp-content folder, just make sure when you enter the wp-content/uploads you don’t put a / at the end of it!! Otherwise it will do a // in your error message url. I also ticked the “use lagacy hacks” in the WP-> Misc. Admin. Screen, even though I have NO CLUE what that’s for… but after I made these changes, it all worked, so I left it!!!haha

    So, I can now upload my images, BUT… there is no option to comment! No pretty comment box like Matt has, no link, nada! When you click a thumbnail to see the larger version, it changes to an attachment url id, which I think it the reason it won’t take comments… ??? I dunno… just guessing. I’ve spent WAY too much time sorting all this out… my eyes are crossing and I just want it to be “right”!!! 😉

    Check this solution, if it helps you to solve your problem.

    I also get the error: The uploaded file could not be moved to /home/beadner/public_html/wp-content/uploads/2008/04. 93

    I tried the solution Rok suggested for the .htaccess file. I also tried changing permissions to 777 but of course, changed it back because that’s a big no-no and I don’t need to get hacked again.

    Help please.

    my site is, using version 2.5



    I compared my settings to another blog that I run and saw that some of my uploads files were set at 777 on the other one, and the image uploader worked. So I tried again on the site for just the most current upload folder and it worked.

    However, this makes me nervous, as I’ve read over and over that permissions should not be 777! Is there an alternative solution to this? I am going to put it back to 755 and will temporarily do 777 to upload but that is a pain.

    @ lorigreenberg: we’ve put everything on 777, but the problem persists. I think 777 and 755 should be equally functional.

    Problem solved! The entire explanation of solving it for my setup can be found in this thread. Chmod 777 and 755 do seem to make a difference.

    Can anyone help me, I can´t se my picture in my posts. First it was just a white box, then I looked around a bit, and suddenly a little white x pups up (this when I uploadet pohoto again, and changed the location of the picture to wp_content/uploads.. when I did this again a little blu box with an white question mark pops up. Still no picture.
    Then I changed the style.css in my theme on this site; “” then I downloaded a lot of plugins such as; User Photo, ImageManager, Flexible upload.. And all I get is this little graybox in left corner when I view my website. And on my admin-site where I write my posts it only displays a white box with a blue little box and white question mark in it, where the picture sould be. What do I do?!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘image uploader, still! tried all fixes’ is closed to new replies.