Support » Fixing WordPress » Image uploader stalls at 'crunching'

  • I have a website that is powered by wordpress 3.5.1.

    When I am uploading certain images it stalls at the ‘crunching’ phase. If I go back to the library, I can see the images there, but I cannot edit them, and no thumbnails are created. This only happens for some images, and it seems independent of image size or shape or any other pattern I can identify. I can upload other images with no problems more than half the time.

    I have tried many of the troubleshooting steps on the wordpress side:
    -changing .htaccess so bump up allocated memory
    -disabling all plugins
    -reinstalling wordpress
    -using the browser upload function
    -clearing the cache

    I have dug through the forums and it looks like other people are having the same issue, however there seems to be no consensus on what the actual fix is.


    At this point I have no idea what to do!

Viewing 14 replies - 1 through 14 (of 14 total)
  • -Can you tell us how many files are being uploaded? Does just one at a time work? Do 5, 10, 20? How big are the files being uploaded? 200KB 1MB 5MB ?

    -What is the total size of the files combined being uploaded? 30MB? 80MB?

    -Have you optimized the files for web prior to upload?

    -Do any of the files have special characters in the file names such as commas, exclamations points, ampersands, dollar signs?

    What are the file types?

    -Are you using default WP Gallery or a Plugin for images?

    I’m just uploading one at a time.

    The file sizes are approximately 1MB.

    Optimized the files for web? No, Im not sure what this would involve. Re-saving them as a smaller size? I’d prefer not to do this, and besides, the file Im uploading doesnt seem that huge anyways.

    No special signs in the file names. They are literally just downloaded off the camera. I tried changing the filename then re-uploading and it still didnt work.

    file type is JPG File (.JPG)

    Im using the default WP gallery. No plugins, Ive disabled them all. I tried using an alternative flash plugin to upload, but it had the exact same problem so i got rid of it.

    OK, well then it sounds like a server issue – have you contacted your host?

    Yes, they said: “Please do check your plug ins if does not need 10 MB of PHP memory limit , and if it requires PHP directives be enabled you may do it using a php.ini file. Below is the link for more information about configuring your PHP directives:

    If you have any further questions please do not hesitate to contact us”

    I’m not sure exactly what that means, but Im looking into it. I’ve checked the .php memory limit by putting a phpinfo file in my directory, but I’m not exactly sure where to look to get the right information. It seems like its saying 90M, which should be enough, but Im not sure thats what its actually set to.

    OK well that is good that you verified using the php.ini file.

    there are multiple lines in that file that can affect this:

    max_input_time = xx
    max_execution_time = xxx
    upload_max_filesize = xxM
    post_max_size = xxm
    memory_limit = xxM

    Try these (the last one is a security thing)

    max_input_time = 60
    max_execution_time = 120
    upload_max_filesize = 64M
    post_max_size = 64m
    memory_limit = 256M
    expose_php = off

    You have to restart the server or use host account to restart server processes after making edits to php.ini.

    Then recheck your phpinfo file, the values on left are server defaults and on right yours (usually), if your values do not appear there, then they may need to be lowered – but again ask host.

    BTW, have 1and1 read this:

    Oh, and just for a test, rename any of the files to filename.jpg <===all lower case and try…

    Ok, great! It appears this is working now, and I can even upload multiple files at a time.

    I created a php.ini file and put it under wp-admin folder with that snippet of code you have above.

    However, I still have a little bit of an editing problem where it wont rotate the image in the media editor. However, if I scale down the image to ~1200×900 or so, it then rotates and edits just fine. I can live with that. c’est la vie!

    Also, thanks for that security tip 😉

    Ok, now this is very strange. The problem seems to have returned this morning.

    I didnt change anything from last night, so I really have no idea what could be different today, or why the issue would return.

    I emailed 1and1 to see if they can shed some light on this.

    1and1 keeps telling me that I may be going beyond the allowable memory usage on their side.

    The maximum they allow is 60M.

    How can I check if Im exceeding that?

    Ok so i’m on wordpress 3.8.1 and i was having this issue and i tried EVERY FIX from every post i could find on this problem of the image upload staying stuck on “crunching” or having it say “image data does not exist”

    So apparently if the image dimensions (e.g. 1920×1080) are bigger than what you have set for your “maximum width” and “maximum height” in your Settings > Media, then you will have this issue.

    I set my max width to 2200 and my max height to 1300 and now my bigger images upload with no problem!!!

    Finally!!!! i hope this helps anyone out there

    Same problem here with a few other weird symptoms:

    • the insert media pop up never loaded properly
    • the image size options were missing
    • Firefox would go loopy on me and eventually have to be shut down

    My error log showed errors starting on the day several large images were uploaded. The images affected were 895 x 1084. I tried your suggestion, changing max size from 1024 x 1024 to 3200 x 2200, but it didn’t help.
    Only after I deleted all the errant images was the issue resolved.
    Even stranger, is the fact that one image uploaded with the “bad” images was 3264 × 2448 – and that one worked fine. And I also know on several other sites I have images that exceed the max size without a problem. The only difference being the problem site was auto updated to v3.8.1, the others are still on older versions.
    So I’m not sure what the real cause of the problem is – I suspect we’ll find out it has something to do with the auto update process. Maybe it fired while the images were being uploaded, which corrupted them so they had to be deleted?
    There do seem to be a lot of different problems users are experiencing after an auto update, so that seems a likely cause.
    Thank you anyway for motivating me to fix my issue!!

    Just to note you guys: I have exactly the same symptoms as webbrewers has. I have also tried to update to latest WP, but it doesn’t seem to fix the issue.

    I have also contacted the host, but they haven’t replied yet.

    I’d be really happy to hear if anyone finds a fix for this.

    According to my host, most of these symptoms seem to be attributable to the image processor WP uses, Imagemagick, having memory issues on some servers. I’ve been able to resolve it on several sites that updated to 3.8.x with a combination of plug ins – one that doesn’t appear to be available anymore and Force Regenerate Thumbnails.
    I’ve also heard that this plugin, which forces GD to be used as the processor, fixes it in many cases:

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Image uploader stalls at 'crunching'’ is closed to new replies.