Support » Fixing WordPress » Image uploader problems with 2.7

  • I’m having several issues with the Image Uploader in 2.7. First, when I try to use it in Firefox, instead of doing the normal popup script, it opens in a new page, taking me away from the page that I was blogging on. Then, after I get the image uploaded and described and everything, I hit to insert it into the post only to have it take me to a blank page. Meanwhile, in Opera, the image uploader shows up as it should and it partially works. It inserts the image just fine, but the caption box does not appear around the image and it puts the caption to the right of the image as regular text. Not only that, but it does not give it the orientation I tell it.

    I’ve tried the suggestions in the image/media uploader thread that is stickied, but it didn’t help. This stuff worked just fine in 2.6 and before, I’m just having the problem with the latest install of 2.7. Any help that anybody can give me would be greatly appreciated. Thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’m having the same exact with getting a blank screen after hitting the insert image button when using Firefox.

    I am having this issue – and have narrowed it down to being theme related (I am pretty sure) because I have multiple wp sites going and only have this issue on one site, another site with older version of the same theme works fine. If I change theme on problem site – I can make image/media uploader work fine and that is what I have been doing as a work around.
    I have confirmed this using the four browsers I have. The theme I am talking about is Royale 1.5.1 It also has non-working trouble in the publish info / privacy area.

    I was hoping others would chime in and say – “Hey – I use that theme too and have the same trouble”.

    i was having this same problem too but have now resolved it – see

    check if your theme is loading any javascripts (you will be able to see them if you view the source code while you’re in an admin screen). if they are, it is probably conflicting with the javascript that the media uploader uses.

    if you’re not a coder, you will need to ask the theme author to change the theme so it doesn’t load the javascript on admin pages.

    hope this works for you too.

    Was having the same problem. Turned out to be commentluv plug-in was conflicting with something. I deactivated it, and no more problems.

    I”m having the exact same issues. I’m using the Flock Browser though. I’ve deactivated comment luv but no good. Still same problem. I’m using the Coldstone theme.

    I’ll check the java script stuff. I’m sure it’s using Java because it’s one of the themes that requires permissions for the post to show up on the front page along with others and change images.

    Ok so I deactivated ALL of my plugins and even changed themes. Still the same issue.

    I can upload images onto my server and the images show up but once I attempt to insert them into a post I still come up with a blank page.

    I’ve chmod, turned off plugins and chanted over candles….still nothing.

    Anyone have any other ideas? wordpress doesn’t seem to be any help with this.

    I’m pretty sure it is the java-script loading in the admin area issue that is causing my problem (with the Royale 1.5.1 theme). I am not a coder… I cannot get a response from the theme creator either, so I am sorry to have to look for another theme.

    I’m having a similar issue as well. I’m putting together a new review site, and I was trying to insert a photo for my very first post when I noticed that I’m missing the clickable button in the menu line (bold, underline, blah…..) to insert pictures. I have a button above in the add media, but when I use that button it puts my picture where I want it, but the text doesn’t flow around the picture; instead it starts the text under the picture.

    I also noticed that I’m missing the pulldown button to adjust the font size. If anyone has any idea how to get these buttons on the menu line, I would love to hear from you.

    Thank you,


    Yes it is a Royale theme problem, and there are probably even more themes that do not work. Any solutioons?

    This sounds similar to my problem. When I go to insert an image onto a new page that I am attempting to add—via the browser-uploader, URL or the Media Library—when I hit the insert tab, the cursor just blinks within the middle of the pop-up window and nothing ever happens. I have tried it using several themes, including the default and classic themes, and all I get is a blinking cursor. The image is never inserted.

    It’s a pain. I can only load images into the sidebars. Does anyone know what the issue is?

    Did any of you guys ever resolve this issue? I’m having the same issue where the upload screen goes blank when I click Insert Image. And then it just freezes there. When I close it, the image isn’t inserted.

    It’s not the theme though because I have an identical site running on the same server and it works fine! I actually copied this site directly over to my new site – database and everything. Made the necessary changes for it being on a different domain. Everything works fine… except this. But the image uploader still works perfectly on the old site. It doesn’t make any sense.

    Really surprised nobody at WordPress seems to have any idea.

    So, nothing? No one has been able to figure this out? I’ve counted about 15 people in various threads here who have posted about having the same problem. It’s certainly not limited to just one or two people. I’m pretty surprised no one is getting back to us about this.

    I just started with the problem today within firefox only. I fixed it in Firefox by going to Tools Add-ons and disabling Java Quick Starter 1.0. All is fine now.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Image uploader problems with 2.7’ is closed to new replies.