WordPress.org

Support

Support » Alpha/Beta » Image Uploader problem in 2.5beta?

Image Uploader problem in 2.5beta?

  • I downloaded and installed 2.5 a couple days ago and noticed a problem with the image uploader freezing when I’m trying to upload images from my computer. See here. As a rule I turn off the visual editor, and tried uploading with it both on and off with no luck. I even upgraded to the latest beta release (3/12/08) and still can’t seem to get the images up.

    I haven’t been able to find any mention of this anywhere so I’m just wondering if anyone has come up against this and how did you fix it?

Viewing 15 replies - 1 through 15 (of 43 total)
  • I’m experiencing same problem. (downloaded 3/12/2008) version Beta)

    Downloaded 3/18/2008) version Beta RC1 – same problem. Please address this.

    I’m glad someone else is bumping this. I too just upgraded to RC1 and am still experiencing this problem. I would love to upgrade my blogs to 2.5 but until this issue is resolved I can’t.

    agreed I have tried everything on my end to make sure it wasn’t some silly mistake but I can assure you it isn’t. hopefully this is fixed soon so I too can upgrade my blogs.

    I think there may be more than one problem with uploading, which is causing some confusion.

    There’s a definite problem with the new Flash uploader on Macs, which you’ll only experience if your web host has the Apache mod_security module loaded (and I think a lot of hosts do). The problem is with the Mac Flash player sending the upload in a slightly incorrect format that mod_security doesn’t like. Because it’s a problem with Flash player it needs to be fixed by Adobe not WordPress.

    It is possible on some hosts to turn off mod_security for the wordpress file that processes the upload. If you’re feeling technical there’s more info on the WordPress bug tracker.

    I was wondering how soon or when I will be able to download patched version of beta 2.5? I was dumb enough to upgrade my production blog. Unfortunately, it uses images heavily. Presently, I have to go through the pain of uploading the images via ftp. One more reason to “think, the do things”.

    PS: I noticed that there was some resolution in the bug tracker and I just wanted to say thank you to everyone involved. I’m still looking for the answer on the the question above 🙂 Thank you, again.

    Hello,

    I just upgraded to the latest 2.5 RC1 from 2.3.3 and I also have this problem, I can’t upload any images with the image uploader. The thing is I’m not using a mac. I run Firefox under Windows Vista.

    When I try to upload I get a HTTP error, and the Flash debugger gives me the following error:

    Error #2044: Unhandled IOErrorEvent:. text=Error #2038: File I/O Error.

    I hope you will be able to fix this. Thanks!

    I wasnt able to upload images on Ubuntu with FF2.

    However, I was able to upload images 1 by 1 on my Windows XP machine with IE7 (not with FF2). While sending the images into the post I noticed another issue:

    If I’m trying to post an uploaded image with the size of 610 by 380 in full size mode, uploader automatically adjusts the width property to 500.

    pardon me for bumping this post

    I’m with ya on the bump!

    I am using Linux and have this problem when using FF, but am able to upload when I use IE6 (thru wine). Haven’t gone to a Windows machine to try yet.

    Initially I had the same problem, the uploader wouldn’t work, however after changing permissions (775) the situation appeared to resolve itself.
    The directory wp-content/uploads was *not* auto created, but apart from that, I honestly can’t say I observed the same symptoms as reported here. As far as I can see, ownership and permissions appeared to be the issues to resolve, and once that was done, everything else worked just fine.
    Environment: ubuntu 7.10/Firefox 2.x and uploading to WP hosted on Plesk 8.2 running over CentOS.

    Dogshit, I don’t think that’s the problem here. When I uploaded a picture for the first time (back in 2.x) I had also to make the uploads folder myself and give it the appropriate permissions and that was the solution. But this is clearly a bug in WP 2.5 disabling (some) people that use Firefox to upload files.

    I also don’t think it just affects people with a mac, because I don’t own a mac and it also doesn’t work for me. Although it did work in IE7 in the end…

    I’ve tried it on both a XP machine and a mac, and both have the same problem in Firefox. When I disable the Flashplayer plugin the upload works without any errors.

    (Firefox 3.0 beta 4)

    I got a little excited when I read dogshit’s post. I changed permissions and still no luck with Firefox.

Viewing 15 replies - 1 through 15 (of 43 total)
  • The topic ‘Image Uploader problem in 2.5beta?’ is closed to new replies.
Skip to toolbar