Image/media uploader not working properly (4 posts)

  1. smoo
    Posted 6 years ago #

    I have read the previous 'image uploader probs' post which was resolved, but their resolution did not work for me;

    I am pretty familiar with WordPress, having installed many versions on different sites in the past.

    -I'm using WP 2.4.8,
    -My wp-content folder has permissions set to 777,
    -My uploads folder is set to 'wp-content/uploads' in the Miscellaneous settings section,
    -'Organize my uploads into month - and year- based folders' is checked.

    Normally when I upload an image, it says 'crunching' for a moment, then the image thumbnail is displayed, with the alignment/title/caption/insert into post options below.

    In this case, when I hit 'upload' it just shows the image filename, no thumbnail, and a 'show' link that doesn't work.
    In the 'Gallery' or 'Media Library' tabs at the top, it's the same thing: no tiny thumbnail on the left, and a 'show' link that doesn't go anywhere.

    However, coming out of there completely and looking in the 'media' tab on the main WordPress leftnav, there's my image. I can click on it and see a medium sized version, click on that and get the full sized one.
    I can also successfully upload an image into there using teh 'add new' link on the left.

    However, Going back to my page to try and insert that image from the page gallery or the media library still doesn't work.

    Here's a possible clue though:
    I have only uploaded an image into this install of WP today (Oct 1st) for the first time.

    Looking via ftp into wpcontent/uploads/2009/
    there are 2 folders: /09 and /10

    The /09 folder contains my uploaded image (plus the scaled versions of 150x150 and 300x102 that wordpress created when uploading),
    The /10 folder contains nothing.

    I checked my timezone settings and they are set to UTC+1 (Correct for London UK, no?)

    Not sure what else to check..
    Can anyone offer any further suggestions?

    Thanks in advance

  2. esmi
    Forum Moderator
    Posted 6 years ago #

    Have you tried uploading other images or just the one?

  3. smoo
    Posted 6 years ago #

    Hi esmi,

    I've tried several, also deleted them via the media library and tried again. Also deleted the month folders via ftp and tried again. It created the same two month folders and put the images in the wrong one. Very odd.

    Just tried again today and it's putting the images in the /10 folder, but still the same thing is happening, -it's not showing the formatting options.

    I'll try a complete re-install today. Maybe there was a glitch in the matrix or something when I installed the first time :o)

  4. taracauc
    Posted 6 years ago #

    I've had this problem for each of my wordpress installs and I have finally figured it out.


    On your server in directory in wp-content folder create a new folder call 'uploads'

    Then login to wordpress and under the Settings -->Miscellaneous
    there is a section asking 'Store Uploads in this folder' enter wp-content/uploads (even if it says something else or is blank)

    This worked (finally!) for me

Topic Closed

This topic has been closed to new replies.

About this Topic