[resolved] Image Uploader Not Resizing Images (6 posts)

  1. Brent
    Posted 7 years ago #

    This is more of a web server question than WordPress.

    I'm running a Fedora web server with the latest versions of Apache, PHP, and MySQL.

    Everything works fine, but when I upload images WordPress doesn't resize them. Can anyone please point me to the right place to figure this out?

  2. Brent
    Posted 7 years ago #

    I figured out that it is a problem with how libgd is configured or installed with PHP. Anyone know anything about this or a good place for me to find answers?

  3. Brent
    Posted 7 years ago #


  4. Brent
    Posted 7 years ago #

    The solution for me was two things:

    1. php-gd needed to be installed.
    2. The html folder's permissions needed to be set to:

    Apache as the owner with create and delete folder access and file access to read and write and Apache as the group with create and delete files for folder access and read and write for file access.

    Hope this helps.

    LOL, looks like I just needed to talk it out here.

  5. xanathon
    Posted 7 years ago #

    I have the same problem

    But as I do not have access to the server settings or shell access (the blog is not hosted by me) I'm only able to set CHMOD and not CHOWN.

    Why the developer choose to change the behaviour like that absolutely eludes me, it makes no sense at all. 2.3.3 worked fine, 2.5 is a desaster.

    The same goes to the decision that we cannot reuse the images already online (before the installation of 2.5). superfluous redundancy and not very efficient. Not everyone has unlimited server space.

  6. Eric Musser
    Posted 7 years ago #

    I changed the ownership of the upload directory, but it did not fix the resize issue. In fact, in interfered with being able to upload images via WP at all so I changed back to default group/owner. Uploading is back to normal (although sketchy since it often appears the image isn't uploaded, yet it shows up in the gallery), but resizing is still not functioning. Any other suggestions?

Topic Closed

This topic has been closed to new replies.

About this Topic