Support » Fixing WordPress » Image Uploader – HTTP Error at Crunch/No Thumbnail

  • I, like many others, have been getting the HTTP Error at the “Crunching” stage of image upload on WP 2.5 One thing that I’ve noticed is that the full-size image is successfully uploading (although the Image Uploader gives the impression that it hasn’t – it also says “An error occurred in the upload. Please try again later.”). However no thumbnail image is created.

    I’ve just adjusted some photos in a program so they are thumbnail size, and uploaded those through the Image Uploader on WP. This time round, the uploading happened with no error – and thumbnails were created by WP of these (smaller, already thumbnail size!) images.

    It would seem that an issue that I was having, and other people could well be having this too, is that WP throws up the error when the photos are too big. The photos I was getting an error on at dimensions of 1600×1200 and in the range of 1-1.5MB.

    If this is the reason of the error happening, then I would imagine it would be happening a lot as modern digital cameras produce images this size, and larger. It’s not very convenient if you have to adjust photos before you can upload them onto a blog – and potentially not possible for people travelling or otherwise away from their computer.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Hi mojorob,

    because crunching takes RAM and CPU on the server side and big images take the square of their size of such you need to properly host and configure your server and php to handle this flawlessly.

    Many hosters do limit the amount of RAM and CPU your scripts are allowed to consum resulting in wordoress not crunching your images to thumbnails.

    So there are two solutions:

    1. You tell your hoster you need a PHP configuration that can utilize more CPU and RAM Resources.
    2. You can reduce the amount of CPU and RAM PHP needs to crunch your thumbnails by submitting smalled Images

    The second scenario is what you already did and you are unconfident with. I sugget the other alternative then.

    I’m not saying that I’m unhappy or whatever with the 2nd option you mentioned, and the one I tried. What I’m saying is that some of the large number of people who are creating new threads and adding to existing thread on this forum in regards to the error at “crunching” may well be suffering from the above but not be aware of it.

    This is particularly the case, as I said, when modern digital cameras produce large images. Anyone who isn’t that technical (which I would guess to be the far majority of WordPress users) may not be aware of server issues as you mentioned.

    So really the only way to make it so I can upload large images in 2.5 is to contact my host and see if they can give me access to more CPU and ram? What is so different about 2.5 that makes it this way? Before I upgraded I had no trouble with uploading and making thumbs out of large images.

    Update: ignore this post… I proved myself wrong.

    I’ve noticed this error too, but have narrowed it down to image width and not file size. It appears WP 2.5 won’t thumbnail an image over 500px wide. Checked out the threads on modifying media.php but that didn’t work for me either.

    I’m doubting this is a server-side issue since I can upload and resize images fine in Gallery 2.

    However, I can’t stand Gallery and WP 2.5 is so damn promising if I could just fix this upload problem.

    wow thats funny. I took a file that I was trying to upload that was 1280x1024px and made it 500×1024 and it made a thumbnail just fine. I actually made the filesize larger as well just to make sure it was not filesize. I wonder if its some hard coded value in there that we or they can change.

    I upgraded to 2.5 yesterday and have the same problem. I always edit my photos to be 1000px at the longest point (width for regular pics and height for vertical pics)and let the other dimension resize proportionally. I always have used firefox, now when i try and upload i get stuck at the crunching stage and get the HTTP error. I decided to try IE6 to see if I was able to upload there, and I was able to, although IE doesn’t create a thumbnail so I was not able to insert the pic in to the post. (also noted that i couldnt see any thumbnails in IE, even for previously uploaded photos, nor could i click on the “show” link) But once i went back to firefox, i could see the thumbnails and finish posting.

    As per the posts above, I tried making my files really small and uploading via firefox. Unsuccessful, even when i made the file 175×175 and it was 48kb

    I don’t think it has anything to do with file size or width, at least not with those limitations. I’m getting the error trying to upload a 32kb file that is only 221 pixels wide and 227 high. That’s not a large photo at all and I saved it at 75 dpi resolution. This is really annoying. I was so looking forward to making this much easier.

    BTW – Your camera should have settings on it to take your photos for the web at a lower resolution. They don’t have to be that big. 72 dpi is all that a web browser can display. The higher the resolution, the larger your photo size and file size. That’s the key. If you are going to print them out then you’ll need a higher resolution (at least 300 dpi) but you can always lower the resolution in a graphics program before you save them for the web.

    Hope that helps someone.

    Ginger Coleen

    Anyone have any answers to this one yet? It seems weird that 2.5 would get through testing with such a glaring error. I also have tried a number of different sizes with no luck at all. I am working on a Mac in Firefox.

    I have tried this with a fresh install of wordpress. No third party plugins installed. Everything clean and new. I set the entire wp-content folder to 777 permissions to see if that was the problem. No luck. Any help would be appreciated.

    p.s. I love 2.5 so far except for this glitch.


    I logged into my VPS and set the memory for PHP up from 8mb to 16mb and the max file size up from 2mb to 4mb. This should be plenty, I would think, but still no luck.


    Another follow up:::

    I have an account on a shared server through Hostgator. I quickly installed a copy of wordpress on there and tried the image upload and it WORKED! So there is definitely something in my set up of my VPS that is causing problems.

    I will try to figure out what and post it here.

    One More Follow Up:

    Further investigation revealed that the issue on my VPS is related to the Mod Security plugin. When I turn off SecFilterScanPost, I am able to get my images to load in WordPress.

    Commenting out individual rules in my config file had no effect. In fact, I commented out every single one of them and still loading an image would fail if SecFilterScanPost was on.

    The error logs were not giving me great info, so I am not sure what else could be done to get this too work. I am not too happy about turning off my Mod Security and I hope there is another option soon.

    I suspect anyone on a shared host that has mod sec enabled is having this problem.


    Could you possibly give a little more instruction as to how to what exactly to do?


    I don’t know what hosting situation you are in. I have a VPS (virtual private server) which I can control more extensively than a shared hosting solution. I logged into my VPS control panel, found the section that lists controls for the Mod Security plugin for Apache, accessed the configuration file and turned SecFilterScanPost off.

    This means that mod security is no longer scanning certain items coming into my server, which I am not very happy about, but that seems to allow my images to upload without getting the http error. A temporary, but effective solution for this problem, until a better one arrises.

    I hope that helps.


    Hi All

    I was having the same problems and went through all steps, complete reinstall, turned SecFilterScanPost off, and all other ideas. I’m also on a VPS.

    I finally got it to work…

    I set all permissions on the wp-content from 755 to 777, and now it works.

    Hope that helps someone.


    Thanks. I think I can try that too, but not until the weekend when I will have more time to mess up.

    I thought it was something to do with one of the HTACCESS files that I have.

    I got a similar problem.

    Although I am a web designer I don’t know anything about servers and databases, would you be able to give me some directions as where to do this: “I set all permissions on the wp-content from 755 to 777, and now it works.”

    I got some control panels through my hosting company ( but I don’t know what to look for to set these permissions.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Image Uploader – HTTP Error at Crunch/No Thumbnail’ is closed to new replies.