WordPress.org

Support

Support » How-To and Troubleshooting » Image Uploader – HTTP error

Image Uploader – HTTP error

  • Hello,

    This is an issue with the flash image uploader.

    After initial installation, I was able to use the image uploader without any issues. I uploaded two images and it worked perfectly, doing exactly what it was meant to do.

    Now it doesn’t work. Every time I try to upload an image, the progress bar scrolls through as usual then in red letters above the bar it says “HTTP error”. That’s all it says. There is also a DISMISS box on the progress bar. The image doesn’t upload or anything. This is happening every time.

    I don’t think this is a site security issue or anything because I was able to use it before without issue. I have changed nothing in the software aside from adding a few plugins, but nothing to do with flash or images at all.

    I have check my security and various other settings on my site (I’m a network admin) and everything has the proper permissions, etc.

    I can manually upload the files, obviously, and I can use the non-flash-uploader.php script fine as well. I have gone through the sticky about the media uploader and checked everything listed there with no success.

    Just wanted to post my error, in case you haven’t seen it before.

    Take care.

    Scott
    http://www.jccitizen.com

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thanks for the link, but unfortunately, I tried everything there and on the outside site and it is still not working.

    It uploads the image then throws the “HTTP error” while crunching the image. The thing that really confuses me is that is worked perfectly the first two times I uploaded images, then hasn’t worked since.

    Thanks for the help, though!

    UPDATE

    The issue has been resolved. I had to tweak the .htaccess a little more and when I moved the following code to the top of the .htaccess file it works:

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    I put that code at the very top of the .htaccess file, right beneath the # BEGIN WordPress.

    Thanks for the help!

    Note that your host might forbid this function since it is a security vulnerability. You might try to chmod your uploads/* to 755 or 777. Then the above soultion will work.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Image Uploader – HTTP error’ is closed to new replies.
Skip to toolbar