Support » Fixing WordPress » Image Uploader bumps me to admin login page

  • Working with a fresh install of WordPress 2.5, I upload a jpg and it crunches properly, but instead of giving me the option to insert the image into my post, it bumps me immediately to the admin login screen.

    When I login, I get an ‘Error 404’ message. When I check the collection of images later, the image isn’t there.

    I checked and didn’t see this problem listed. If it has been covered, I apologize.

    Thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • Please disable plugins and javascript, then try again to upload that exact file and then report your feedback again in this thread.

    I’ve had a similar problem a couple of times…

    “I upload a jpg and it crunches properly, but instead of giving me the option to insert the image into my post, it bumps me immediately to the admin login screen.”

    However, I can login and the image is there.

    What I find interesting about the above problem and this one as well…

    http://wordpress.org/support/topic/140107?replies=11

    …is that they’re not consistent. Sometimes, I get a blank screen, sometimes I’m asked to login again, and sometimes everything works fine.

    LewiePaine: These inconsistences happen while you are using the same image over and over again?

    no same image…always a new, different image.

    LewiePaine, Have you tried with disabling javascript and cache as well?

    hakre,

    Thanks for posting. I disabled all the plugins and disabled javascript on my Firefox options, and the problem persists.

    same here

    Let’s say a redirect goes gaga, displaying a blank page or at least the session is destroyed and you end up in the login form. mhm. What could cause this?

    hakre,

    Well, thinking about it conceptually, I think it’s possible that though one has to be logged in to access the image uploader, for some reason after actually uploading it goes to access the image (to give the option of adding details and inserting into the post) and finds that it can’t, so it asks the user to login.

    So why does it consider one to not be logged in when clearly they are logged in?

    Just thinking out loud.

    Well that is what I meant with session is destroyed. This can happen if the cookie is blocked or an ajax request maybe.

    Please check if you have a desktop firewall running. Maybe it has a webfilter or similar. Whitelist (allow) the URL/Domain of your blog and try again. Today there was a similar Issue with the Mediauploader and a Desktop Firewall blocking it partially.

    WTF!

    why is Adobe Flash being incorporated into the administrative area of WordPress anyway? Image Manager worked fine for years. are we really that strung out on bells and whistles?

    I loved Image Manager! it worked perfectly, now it’s not even an option.

    Well this one now is with adobe flash I guess to support multiple files etc.. I wonder if the sourcecode of WordPress contains the sourcecode of that flash file as well… .

    hakre & LewiePaine,

    So I decide to try it in a different browser – IE Explorer, rather than my usual Firefox.

    I tried to upload an image and it just held up – no crunching. So I close the box. Then, I check the media files that have been uploaded and the image is indeed there!

    Then I switch back to Firefox and try and upload a pic. Now, everything works fine.

    Strange.

    I did the same as ssc001 and for some inexplicable reason it worked for me too. How bizarre!
    My flash uploader stopped working after my upgrade from 2.5 series to 2.6 or perhaps from 2.6 to 2.61. Anyway, it is working fine now and even if I can’t understand how it works I am happy that this is a solution.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Image Uploader bumps me to admin login page’ is closed to new replies.