Support » Fixing WordPress » Image Uploader and Category Creation Probs

  • Resolved AlexinMilan



    I’ve read all the posts about the image uploader probs and I’ve had a go at sorting out my .htaccess file, plus I have upgraded to 2.5.1, but I’m still having problems.

    A) I can upload images, but only after being asked to login once more.
    B) I still cannot insert images directly into posts via the uploader – all I get is a blank white screen when I hit ‘insert into post’.
    C) From the post writing screen, I cannot create new categories.

    I’m using Firefox 3.0b5, I have lots of tabs open. I have removed cookies and cleared my browser cache.

    What I’d like to know is whether this is a browser problem, a WordPress problem or a problem with my host’s server settings. If the second situation is more likely – what do I need to change to get this all working again?

    I’m holding off upgrading my other WP powered sites to WP 2.5 is working as intended, but I’ve noticed that not everyone has been having problems with WP 2.5 – which I why I think server side issues are causing problems.

    And finally – does anyone know how I can get the image uploader from WP2.3 to work with 2.5? I’ve never had any real problems with WP before now, and I really think it’s an excellent blogging, and general web site platform.

    Could someone possibly give me an example .htaccess file? And tell me, politely, where I should stick it?

    Many thanks in advance and kind regards,


Viewing 15 replies - 1 through 15 (of 15 total)
  • No replies – not a surprise.

    What I don’t understand is why some are having no probs with the image upload/insertion process, whereas others, like me are.

    I’ve even seen people on the same hosting services both with and without problems.

    Time to wait and see.

    OK – done it – the image uploader is now working and I can insert images into posts, and I can create categories again.

    Put this in .htaccess file in root:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off

    …and this in the .htaccess under wp-admin:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    <IfModule mod_security.c>
    SecFilterInheritance Off

    I also followed the instructions in the sticky at the head of this forum a little more attentively (my bad) – and deleted the contents of the js_cache directory, as well as cleaning out my browser cache and restarting Firefox, and I’ve got two tabs on Firefox open.

    I have now re-activated plugins and no probs.

    Now I can start using WP 2.5, and will even think about upgrading other sites.

    Good stuff!

    Moral of the story: Read the sticky and get those .htaccess files right.

    Alex – one is right – that is not FF – my is 2.14 and the same problem! 🙁
    Under IE also.

    BTW. I want to try .htaccess solution, but I dont know, how to create it (what a name is it in file system – in WIN .htaccess is impossible to create – when I moved txt file and changed it name on the server – that file disappear – how to create that file?

    My post is here:


    That the .htaccess files should ‘disappear’ is normal – and they are still there.

    I don’t know what FTP system you use, I use FileZilla, and under the ‘View’ Menu, I just selected ‘Show hidden files’ – then I can see the formerly invisible .htaccess files.

    Hope that helps.



    Tried to use WP 2.5.1, but I’m back to square one – cannot create categories from posting screen, can upload images (after logging in again), but cannot insert images in posts.

    Time to wait for version 2.5.2 etc

    Sorry to have raised a false hope! But, when it does work, it’s very good, but the old system was just as good IMHO.

    If I login to my site using I have the image upload problem, but if I go through the start page by using and then select “Log in” under “Meta” from that page I don’t have the problem.
    Has anybody else seen this?

    Alex, what is the whole name of that file? this: “.htaccess”? I must move any name *.txt file to the server and must change the name after? How to do that – Im not coder, sorry.

    I wait also for next update, WP lost us, ordinary guys, alone with that – maybe writing htaccess myself is ok, but writing any line of the code is not good idea, if I dont know what I exactly do, maybe I will open doors for danger moves from the net?
    I think WP team stop to think about basic things by producing that 2.5.x versions

    Im sorry, that UR WP still not works 🙁

    I’m having the same problem…

    A) I can upload images, but only after being asked to login once more.
    B) I still cannot insert images directly into posts via the uploader – all I get is a blank white screen when I hit ‘insert into post’.

    and like mareksy…

    I’m not exactly sure how to “make an .htaccess file in your wp-admin directory” and insert that bit of code as directed by Otto42 in the sticky. Especially if the “fix” doesn’t even work, as suggested by AlexinMilan.

    I’ve been using WordPress for years and I’ve never been asked to create a .htaccess file in order to make things work properly.

    I’ve very disappointed that this was not corrected in 2.5.1 and as far as “Time to wait for version 2.5.2”


    thanks Alex for your contributions. I changed my htaccess files to be like yours, clears browser cache and js-cache.

    I am now making some progress. The image uploads, and then after Crunching I get the error about “Unable to create directory”. But the directory exists, and I have checked the permissions and they are 777.

    This is with Firefox on a Mac. My plugins are active. Maybe I should try with no plugins.

    Just tried with no plugins — exactly the same behaviour.

    mareksy, LewiePaine,

    What system are you using for getting files onto your hosting service’s servers?

    If you are using a system like FileZilla, as I do, you can left-click and select ‘Rename’ or do a slow double click on the filename and change .htaccessnew into .htaccess, which will then be seen by your sever system. It’s best to rename or delete and existing files called .htaccess before uploading a new one.

    To put the .htaccess file in the wp-admin folder, you just need to find the wp-admin folder – usually in the main html folder – click on the folder to open it and then upload or drag and drop the .htaccess file into the open folder.

    However, as I’ve said, I’m still having problems, even if at one point everything was working perfectly. I think clearing your site’s cookies can also help things. You can do this from your browser – in Firefox – Tools>Options>Privacy>Show cookies – then look for your site url and delete all the cookies you find.

    Good luck!


    Just been having a go at uploading and inserting images via IE7 – and it works perfectly!

    It’s almost as if WP 2.5.1 has some allergy to Firefox, or rather some setting or other within Firefox is causing 2.5.1 to fall over.

    Time for a visit to the Firefox help forums.


    glh3913…I seem to have my problems when I use roboform to login. I thought maybe it was just a coincidence as I have seen no one else mention this. I also noticed that I seemed to get best results from the way you mentioned. (go through the start page by using and then select “Log in” under “Meta”)

    also, I’ve been trying to stay logged in when things are working.

    AlexinMilan…are you saying that there is a file named .htaccessnew or .htaccess included in the downloaded zipped folder 2.5.1? If so, I can’t see it and I saw earlier that “View/Hidden Folders” might be an option but I use CuteFTP and I can’t find such a folder.


    Sorry not to have replied sooner.

    First of all, I recently upgraded another site of mine to WP 2.5 and everything is working fine.

    I used the WordPress upgrade plugin (see the WP2.5 download pages) to carry out the upgrade, and everything went very well, and much more quickly than ftping backups here there and everywhere.

    If you are having problems with this media uploader, before messing with potentially complex .htaccess files – try using the upgrade plugin, and then see if your site works fully.

    Now, back to .htaccess stuff.

    Bascially, a .htaccess file is not much more than a simple text file. You can put whatever rules you want into one of these files, as long as you follow the specific syntax that these rules require.

    A slight word of warning. .htaccess files can really lock down your site – in fact, get them wrong, and they may lock up your site and some of its functions.

    If this happens, just rename the .htaccess file on your server to old.htaccess and read some more until you understand enough to try again.

    I might be wrong, but I don’t think that you can do serious damage to your site via the info in a .htaccess file, but you never know – backup regularly to be the same side.

    Google ‘.htaccess, tutorial’ and you should find something to help you.

    Actually, creating a .htaccess file is simple. You can use Notepad to do it.

    Put the .htaccess info you want into the file. Save it as test.htaccess, and it will be saved as test.htaccess.txt

    Then, once you have uploaded it to your server, just rename the file to ‘.htaccess’ – make sure the ‘.txt’ is removed. The rules you set will then be activated.


    Problems now solved – every thing works – I used the WordPress Automatic Upgrade plugin and all the problems vanished.

    Put the standard .htaccess files back in place if you don’t know how to tinker with these things.


Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Image Uploader and Category Creation Probs’ is closed to new replies.