Support » Fixing WordPress » Image Upload Problem: Forbidden 404

  • This is probably just some silly permissions error (I think), but here’s what’s happening.

    Upgraded to 2.5 without a glitch. Perfect, so to speak.

    But, when I upload an image via the “Add Media” button(s) (via image or gallery), the file is uploaded, the three sizes are created (img_3302-150×150.jpg, img_3302-300×225.jpg and img_3302.jpg) and the image is embedded into my post. So far so good.

    What I get in the post edit screen is an image frame (I embedded the thumbnail version of the image for test purposes) with the famous “broken link” icon. In my uploads folder entitled 2008/03/, which was created when I uploaded the image and filled with three images (see above)), they are all in there, right file names and all.

    When I copy the link location and enter it into my browser, I get this:

    You don’t have permission to access /wp-content/uploads/2008/03/img_3302-150×150.jpg on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    So, what am I missing?

    I’m guessing this is a permissions issue, so my first question would be as to what permissions the uploads folder(s) need(s).

    My uploads folder(s) is/are all 710?
    Is that correct?

    If this is not the issue, where could I look further?

    I’m grateful for any help.
    Thanks in advance.

    BTW: I love this 2.5 update. One of the smoothest I’ve experienced these past months. Everything else seems to work like a charm. Not even a hiccup.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Any ideas … I know the forum is beginning to fill with posts in regard to image upload problems, but this one here should probably be easy to fix. Upload went fine, images are there, I just get the “Forbidden” error message.

    Thanks for any hints as to where I should be looking

    Tried 775?

    And everything inbetween up to 777.

    No change.

    The problem must be elsewhere.


    Maybe it’s because I’m in a subdomain I think I read that somewhere but can’t check without putting my new version live and pushing the old out for a while. I don’t feel like doing that because I changed over from EE to WP and need to redirect Google traffic etc.

    I had a similar problem – got a 404 page when trying to insert an image. I solved it by the info in this sticky:

    I used the info from no. 6 of “things to try”:

    6. mod_security might be causing problems. Disable it to see if that is the problem. To do this, make an .htaccess file in your wp-admin directory. Add this to it:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off

    That will disable mod_security for the upload file receiving code in the wp-admin directory.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Image Upload Problem: Forbidden 404’ is closed to new replies.