Image Upload: Unable to create directory - 777 Does not work (6 posts)

  1. adamfolio
    Posted 8 years ago #

    Hi there,

    I installed WordPress yesterday and it's literally been a step-by-step catalogue of errors. Nothing has worked yet first time without me having to read up on how change it, and this latest problem has me at my wits end...

    I'm aware that it's not uncommon to get the error:
    Unable to create directory C:\Sites\Single6\whatsonsouth\webroot\adamportfolio\Wordpress\Wordpress/wp-content/uploads/2008/03. Is its parent directory writable by the server?
    Back to Image Uploading

    When trying to upload images. ANd I've read that most people suggest to change the file permissions to 777. Everyone I've read seems to be happy with this, but it simply isn't working for me...

    Does anybody else have any ideas? I'm going insane here!



  2. Clayton James
    Posted 8 years ago #

    change the file permissions to 777. Everyone I've read seems to be happy with this, but it simply isn't working for me...

    This is how I have done it. I can't speak for others, and I don't use a Windows server, so...

    Temporarily change the wp-content folder permission to 777. Upload a file from WordPress allowing it to create the "uploads" folder. Change the permissions back to 755 on the wp-content folder. Permissions on the uploads folder need to remain 777. That works for me.

    Safe? Not safe? Different method? I too, would like to know if there is a better way.

    Best of luck.

  3. cilipadi
    Posted 8 years ago #

    From what I understand, in adamfolio's situations:

    says, /Wordpress/wp-content/uploads/2008/03 cannot be created. And the "parent directory" include wp-content, uploads, and 2008.

    if your system exist WordPress/wp-content, and there is no any subfolder under wp-content, then this folder is the parent directory, and should set to 777.

    if your system exist WordPress/wp-content/2008/02, and the wordpress is trying to creat WordPress/wp-content/2008/03, which mean the folder should set to 777 is 2008, instead.

    hopefully this will help


  4. arminbw
    Posted 8 years ago #

    I guess it´s a bit too late..


    You need root access.
    Or you just deactivate the month-year-folder option...

  5. twop
    Posted 7 years ago #


    I was playing with some of the settings that weren't mentioned in any of the posts I found on the forums and was able to fix the problem WITHOUT messing with permissions and safe-mode. When logged into WordPress dashboard(wp-admin url page) I went to settings>miscellaneous. I changed 'Store uploads in this folder' to 'wp-content/uploads' (mine was this by default but I made sure it was this since I read it could cause this problem if it wasn't this), then I unchecked the 'Organize my uploads into month- and year-based folders' box. Unchecking this box and saving the changes is what solved my problem.

  6. pauro
    Posted 7 years ago #

    works for me in 2.71


Topic Closed

This topic has been closed to new replies.

About this Topic