Support » Fixing WordPress » Image upload returns empty after working for several months

  • Resolved michaelgracie

    (@michaelgracie)


    This morning I tried to upload an image from within a post. This is the third time I’ve used the feature – it worked fine on the other two occasions. It didn’t work – I was returned a simple blank upload block. Tried again and again. Same result – no upload. The file is a 400k pic – jpg – pretty simple.

    There have been no changes made to the install. The wp-content/uploads directory is 777, and the previous pics are in there in the proper directory structure. The apache logs show no related errors. The drive is only 18% utilized.

    The only difference between now and then is I changed a pic, deleting a previous version and uploading a new one, roughly two weeks ago.

    I’ve made one .htaccess change as well, a 301 entry to redirect a stray link I found on the web to the proper post.

    In other words, the thing just quit working.

    For troubleshooting, I’ve reset and saved the related directory permissions, restarted Apache, assigned the uploads directory from root to apache and back to root again, rebooted the entire server, cleaned out the cache directory, optimized the tables, rebooted the Mac I’m working off of, tried uploading from Firefox, tried uploading from IE and Firefox on a Parallels Windows install, tried uploading from Firefox on a Parallels Linux install – etc.

    Any additional thoughts on troubleshooting this?

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Image upload returns empty after working for several months’ is closed to new replies.