Support » Fixing WordPress » image upload results in insufficient permissions?

  • Resolved disturbedcooking


    Hi folks,

    I installed WP 2.8.1 today and it is basically working all right.
    When I upload an image for a post, the upload works and the thumbnails are created correctly but the images are not displayed in the post.
    After some investigation I found out that the permission flags of the uploaded files are set to 600 (owner read and write) and as soon as I set this to 640 or 604 manually, it works. Is that some configuration issue or something?

    I had a WP 2.7 installation running some months ago on the same server and in that installation it used to work.


Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi out there!

    Is this really the only topic that nobody has an idea for? I played around a little bit and did not find a solution so far.



    Assign 766 recursive permissions to wp-contents folder which will resolve the case..

    Do not install the plugins which are not compatible with your wordpress version which may corrupt the file permissions


    Shane G.

    Hi Shane,

    thanks but that does not work either. I have absolutely no idea. I don’t even get the picture shown when I enter the full address in the browser. Any other ideas?


    After I deleted the whole thing and started from scratch, it worked after I set the folder permissions to 755! Now the pics get 640 as permission and it’s finally ok!
    It seems to be a problem of my provider (

    I upgraded one site from 2.8 to 2.8.4 and the file permissions of folders are mostly 755. The files are 644. So for the theme 755 and 644 for the files in that folder including in the images subfolder. I have tried other permissions on some of the files. The header image of the theme won’t display. I will retest that them elsewhere but it does work on other hosts and has worked for 2+ years on this one.

    I did try “Assign 766 recursive permissions to wp-contents folder” that stopped the site working altogether.

    The second issue is that images on the uploads folders /wp-content/uploads/2009 are not displaying at all.

    folder settings are 755. and file settings – mostly photos are also set at 755. I have tried the reset to 644 or something else and only get “Operation not permitted”

    That looks like a separate permission error so asking the host about that one. I suspect that if I can make all the images inside the upload folders rest to 644 then we will be able to see them again.

    But that isn’t working for the theme image header file.

    I’m going to test on another host and try deactivating all plugins – however this is an old site and everything has been working well until the last 2 upgrades. 2.8.2 & 2.8.4.

    I do the upgrades manually on this site. My topic is not resolved – but not sure how it is different to the above scenarios.

    Turns out some permissions were changed.

    In the meantime we changed themes and that has given us a temporary fix. It may be that the old theme didn’t support 2.8.4.

    Consequently the problem is fixed for now but not really resolved.

    Since your hoster is try the plugin from Sven Kubiak “Change Uploaded File Permissions”

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘image upload results in insufficient permissions?’ is closed to new replies.