Support » Networking WordPress » Image upload problems for multisite subdomain site

Viewing 14 replies - 1 through 14 (of 14 total)
  • (Network Admin / Sites / Settings)
    Upload path: wp-content/blogs.dir/2/files
    Fileupload url: (I also tried and didn’t work)

    That’s wrong… Your fileupload URL should still show as (yes, I know it’s weird, but that’s how domain mapping works).

    What domain mapping plugin are you using?

    Did you verify that allowoverride is set to all on your httpd.conf?

    I’m using WordPress MU Domain Mapping plugin.

    Allowoverride is set to all.

    I’m also looked at blogs.dir folder ownership (chown) set. its user and group are same.

    What am I missing?

    Did you check to make sure that uploads worked before you mapped the domain?

    Yes I did. Currently, uploads are working on unmapped mainsite.

    At first, I set the my main site address as instead At that time uploads were not working. And later, I changed it to (manually search and replace in database). Still didn’t work. Could that be a problem?

    Thanks for trying to help me Ipstenu.
    (And sorry for google translate, my english isn’t so good)

    It’s okay 🙂 You’re doing fine!

    Are you trying to map the main site on your domain? You can’t do that.

    You can map the subsites only.

    No I’m not trying to map the main site. (or am I? Here is the screenshot of my network sites section:

    There is no problem at the main site.

    I mapped the subsites only as you say. My uploads at the subsites are not properly working. When I look at the uploaded image path, it’s showing (which is broken)

    I also look at the blogs.dir folder, I see the uploaded image there:


    Apparently the image is successfully uploading into the blogs.dir folder. That’s fine. But I can’t see the image on the subsite.

    I’m exhausted now 🙁
    Thanks for helping again.

    Look on the far left of that screenshot. See how it says / ? That isn’t right 😀

    Are you using subfolders for your subsites? Because if you use subdomaains (i.e ) for your sites, then that view is wrong, and so is your .htaccess 🙂

    I’m confused. I don’t use sub-directories, I used sub-domains at first install. But, when I look “Settings – Network Setup” section I see the setup codes like this ss:

    on that screenshot, htaccess codes are for sub-directories. am I wrong? But I checked sub-domains at first install.

    I tried that htaccess codes though, didn’t work too.

    You said that view is wrong, what do you mean that? How should be that for right view?

    Sites should look like this:

    See how I have one with / and the rest have the name of the subfolder? That’s what’s wrong. EVEN when you map a domain, that stays true!

    Did you edit those sites manually instead of using a plugin?

    Yes I did edit manually, because when I add a new site it looks that: in sites/info – domain field

    which It’s not open in this way. So I edit that field as
    Than is opening.

    because when I add a new site it looks that: in sites/info – domain field

    You’ve done something very wrong.

    The domain column should have the orginal name of your subsite. So if you named the site, then ‘site5’ shows up in domain.

    The Mapping column should have the domain name

    You should NEVER EVER have to edit the sites manually. Otherwise what’s the point of the plugin. You mapped things ‘wrong’ and I don’t know how.

    If I don’t edit manually, the subsites are not opening. I guess I’ve done something very wrong as you said. But what or where?

    In wp-config, I set the domain_current_site as
    Otherwise the main site is opening without www part. I dont want that. So do you think that adding www part be a problem?

    Another curios:
    Server IP address is empty in domain mapping configration page. Should be entered my mainsite ip address?

    And last, what do you suggest, should I delete all and return single installation and then start new multisite configration again? (I already have 4 subsite with content by the way)
    Or should I contunie in this way? (because the subsites are working except image uploads)

    Addition, these both are not opening:

    only when I manually edit site as
    then working

    I don’t know what’s wrong.
    Hope you help me Mika is the wrong page.

    That’s the page where you add domains, not the domain listing. See on the menu on the left it has ‘Domains’ below? Click that.

    Was any of this working before you started mapping domains?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Image upload problems for multisite subdomain site’ is closed to new replies.