Support » Fixing WordPress » Image Upload Problem (WordPress Adds Wrong URL)

  • Resolved sethdickens


    Hi Folks,

    I’ve been having a series of image upload problems on my WordPress v2.51

    At first I was having the same problems as Otto42 has described a fix for above (the flash-based uploader was returning and “HTML Error.” I added a line of code to the .htaccess in the directory root, and it nearly worked. My images uploaded, but now they are coming up with broken links.

    What is happening is that:
    Instead of giving my images a URL of e.g.:×225.jpg

    they are coming up as:×225.jpg

    in other words WP seems to be adding my domain name twice to the links.

    The strange thing is that if I look at the post in html view before publishing it contains the correct URL, but as soon as I publish it adds this double URl.

    If anyone has any ideas or suggestions I’d really, really appreciate your help.


Viewing 2 replies - 1 through 2 (of 2 total)
  • Shouldn’t you just be typing in the actual image name? If you’re typing in the entire URL that’s the problem. Have you declared your default uploads directory in Settings (should be /uploads)?

    Hi there joinmueller, thanks for the reply, and thanks for pointing me in the right direction to fix the problem!

    As it goes, I wasn’t typing in the url, just letting WordPress “Insert it into post” for me. Bloomin thing was adding the huge long url for me.

    The reason was, that in my misc settings page I’d completed the “Full URL path to files (optional).” I deleted this entry and Yaay! It works!

    Now out of interest, should you ONLY complete either:
    “Store uploads in this folder”
    “Full URL path to files (optional)” on the settings page?

    Anyway, Joinmueller, thankyoiu for your help, I really appreciate it.


Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Image Upload Problem (WordPress Adds Wrong URL)’ is closed to new replies.