WordPress.org

Support

Support » How-To and Troubleshooting » Image Upload problem! Help!!!

Image Upload problem! Help!!!

  • I’ve just launched my new website/blog, and all was fine with 3.3.1 on localhost. I moved everything across to my new server … and all was well.

    When I tried to add a new image to the media library, alas WordPress fails somehow in adding this to the Media Library. The item shows in the media library, but with no thumbnail.

    When I press “Edit Item”, I can see the image … which is even weirder.

    Any help would be greatly appreciated.

    BTW, I’ve tried changing the theme, and it results in the same. I’ve also tried deactivating all plugins, but that didn’t do anything. HELP!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Have you checked that your server has PHP image processing (GD) enabeled?

    How do I check that? That option doesn’t seem to exit on my hosting company’s control panel!!

    Try to ask your hosting company, most have a live chat or phone number.

    You can also check via a short php script, but contacting your host is faster 😉

    Ok. I uploaded an PHP file that outputs whats enabled on my server … and GD is enabled.

    Does the server log any error messages (check via ftp)?

    Does php have write access to the server?

    Could be several causes….

    This is the only thing in the cgierror.log file:

    PHP Warning: Invalid argument supplied for foreach() in /wp-includes/shortcodes.php on line 296
    PHP Warning: Invalid argument supplied for foreach() in /web/wp-includes/shortcodes.php on line 296

    (process:15450): GLib-WARNING **: getpwuid_r(): failed due to unknown user id (67671)

    (process:15450): libgnomevfs-WARNING **: Unable to create ~/.gnome2 directory: No such file or directory

    … does this make any sense to you? I appreciate you help, btw!

    Thanks for your help. It was a permissions fault on the folders that was causing the problem. I must have happened when I copied the folders from my localhost site.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Image Upload problem! Help!!!’ is closed to new replies.
Skip to toolbar