Support » Fixing WordPress » Image Upload Problem

  • I have been trying to get a straight answer on the fix for this problem since I first asked it about 2 weeks ago, and still I have gotten nothing, I am getting the following error:

    Unable to create directory /var/wwwvhosts/liftnw8sblog.com/httpdocs/wp-content/uploads/2006/05. Is its parent directory writable by the server?

    Now I have changed the file permissions on wp-content to 777, which allows full read and write access to this directory but I still get this darn error. I have someone else running two blogs on my server space as well who I host and they are having the same problem, all the blogs are using the latest version of WordPress.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thanks, going to try this, I have already manually created this folder, thinking that should fix it right off, but initially it didn’t work, going to check the file permissions on that folder as well and modify if necessary and then give it another go and see if it works.

    just create ‘uploads’ directory under /var/wwwvhosts/liftnw8sblog.com/httpdocs/wp-content/ and CHMOD it to 777.

    Ok, I have now created the uploads directory, and CHMOD it to 775, as the other post instructed, I also CHMOD wp-content to 775 because I don’t want that much access for anyone, and I attempted to upload something and got nothing.

    Ok, I chmodded both directories to 777 and everything worked just fine finally.

    The uploaded file could not be moved to /home/flavorof/public_html/wp/wp-content/uploads/2007/03.
    Warning: Cannot modify header information – headers already sent by (output started at /home/flavorof/public_html/wp/wp-admin/admin-functions.php:1879) in /home/flavorof/public_html/wp/wp-includes/functions.php on line 1219

    I tried uploading an image recently and this came out.

    I’ve been uploading images using the uploader for quite sometime and it just started doing this. Can anyone tell me what went wrong? the only plugin I use that is anyway connected to the image uploads is the lightbox 2 plugin

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Image Upload Problem’ is closed to new replies.