• Resolved jstickney

    (@jstickney)


    We have been using this plugin for custom avatars for a couple of years without an issue. We publish a monthly magazine and add a few new authors with their photo every month. This month, the option to add the custom photo isn’t there on the profile screen. We can’t change photos for existing authors nor can we change the photos for new authors. If we uninstall the plugin and reinstall it, will we lose all of the author profile photos that we’ve set up?

    Honestly, I was a little disappointed to see that I couldn’t “create” a new photo/profile association from the Library view. That’d be another “back-door” type option for when this happens.

    We love this avatar tool and we’re hoping there is a solution.

    What we’ve tried:
    Accessing the profiles from two different admin accounts, 2 different laptops, chrome and safari browsers. We’ve logged out of WP and back in. I’ve updated all plugins/themes and even upgraded to the latest version of PHP all in hopes of fixing the issue.

    I haven’t disabled all other plugins, but if there’s a conflict, your avatar plugin would be the one we drop in hopes of finding another. 🙁 We tried installing another simple avatar plugin over the top, and it allows us to upload a new profile photo like this plugin did. However, the 2nd avatar plugin doesn’t override the default avatar photo from the WP User Avatar plugin settings. So we’re still stuck.

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter jstickney

    (@jstickney)

    We found a fix for this in the configurations. There is a setting: “Allow Contributors & Subscribers to upload avatars.” The checkbox for it had been un-checked.

    Our site theme has “Authors” as a user type. Whoever made the change didn’t realize that setting would have an effect on Author profiles since only Contributors and Subscribers were mentioned. Re-checking the option box fixed our issue.

    For whatever it’s worth, re-wording that setting to simply say “Allow users to upload avatars” would be more inclusive for all themes and more concise in meaning for the end-user.

    • This reply was modified 1 year, 10 months ago by jstickney.

    Hello, I have been facing the same issue. Where did you find the above checkbox? Unable to find the checkbox.

    • This reply was modified 1 year, 8 months ago by khushboogoel.

    Same problem here. but “Allow Contributors & Subscribers to upload avatars” option didn’t fix the issue. any solutions?
    using free Kadence theme.

    • This reply was modified 1 year, 2 months ago by matinsoroudi.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘image upload option is missing’ is closed to new replies.