Support » Plugin: PhotoPress - Image Taxonomies » Image Upload Not working properly with Photopress Image Taxonomies Plugin

  • Resolved Saqib Khan


    I think it’s a great plugin and but I’m having strange problems using it. I’m using WordPress 3.8 and the problem is that whenever I upload an image of larger filesize, (2mb and above) the plugin somehow obstructs it from getting uploaded properly. It doesn’t give any error and the file shows as being uploaded in the media manager.

    But when you try to post it or put it up as featured image, it just shows blank. Moreover, the size of the image is also not shown in the media manager – it just shows ‘a x a’. When you try to scale the image by changing this ‘a x a’, it doesn’t budge.

    Interestingly, the image upload is not affected if the file size is below 2mb or if I disable the plugin altogether.

    Have you put a limit to the file size?

    Are there any other constraints built into this plugin?

    I’ve got four different sites powered by wordpress, and this issue is there on all four of them. I’ve tried disabling all the other plugins to check if there’s a conflict or something, but that doesn’t seem to be the case. Once I disable the plugin, the same picture uploads alright.

    I would appreciate it if you could offer a remedy.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author padams


    There is no limit, but the plugin does have to read the file into memory so your hosting may be hitting a memory limit. I upload 6-7MB files all the time. See if you can figure out what your PHP memory limit is and try upping it.

    I’ve tested the image taxonomies plugin extensively on four of my sites:
    1. Restaurants Uncut
    2. Brandasy
    3. Will Shoot For Money
    4. Travel Hustling

    Two of these sites are four years old, the other two newly minted, with different plugins installed on them and yet all of them face the same two issues:

    1. Images that have not been processed through Lightroom do not get accepted by wordpress as being uploaded although they show up on the dashboard.

    2. Images that have been processed by Lightroom get accepted but if they are smaller than 1.7mb in size. Any size bigger than that and the aforementioned problem occurs.

    After deactivating the plugin, images get uploaded easily, irrespective of their file size or whether they have been processed in Lightroom or not. So it’s not an issue with PHP memory limit.

    At first I thought it was a conflict with some other plugin, but after checking different permutations and combinations on the four sites, even going to the extreme of deactivating all the plugins and keeping only Image Taxonomy activated, the same problem recurred.

    Based on this observation, I can only infer that Image Taxonomy Plugin is not compatible with WordPress 3.8.1.

    If that’s not the issue, and there’s something else causing the plugin to malfunction, I would appreciate it if someone could help me out with it.

    Just to be thorough, I’ve uploaded the screenshots of how the plugin is interfering with the image upload. I’ve circled the things to be noted, viz, the absence of image dimensions and file size, and the error of ‘image does not exist’ when I try to edit the image: dimensions.png file size.png

    It would be great if someone could make sense of this mind-boggling issue.

    Plugin Author padams


    Wild. Can you send me the files that are causing the problem so i can test them on my end? I’m peter at this domain:

    Yep. Wild it is.

    Which files do you need Peter? The image files? If yes, then from which camera? Nikon S910? Sony P10? Samsung S3? or Canon 650D? Have tried uploading from each of these source with no luck.

    However 650D files do get uploaded successfully but that’s because they are shot in RAW and processed in Lightroom.

    Let me know which ones and how should I give them to you.

    The reason I’ve spent so much time trying to make this plugin work is because I believe it offers a terrific functionality which although not for everyone, will aid me tremendously in all of my four sites.

    BTW, the ‘a’ is missing from ‘Adams’ causing your website link to go nowhere.

    Plugin Author padams


    Send me a few of the images files that do not upload and break things so i can reproduce the issue.

    Hey Peter,

    I tried to find some way of sending you the images on your website but to no avail. I’ve therefore uploaded the images on my own domain and mentioning the links category-wise:

    Images processed in-camera as jpg and unable to be uploaded properly:

    Images taken as Raw and processed through Lightroom. They are therefore able to upload properly via this plugin:

    Hope you could come up with a viable solution. All the Best!

    Plugin Author padams


    None of those links work. They all result in a 404 error.

    I’m not sure why you are having trouble just emailing me the files directly. I’m peter at this domain:

    Thank you so much Peter!

    You’ve finally cracked the code. I’ve tested the updated version of the plugin extensively on my sites and it works beautifully irrespective of the size of the image or the camera from which it was taken.

    Anyone looking to work with images extensively on his or her blog should definitely install and make use of Peter’s terrific plugin.

    Great effort!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Image Upload Not working properly with Photopress Image Taxonomies Plugin’ is closed to new replies.