Support » Fixing WordPress » Image upload not working in WordPress 2.8

Viewing 15 replies - 46 through 60 (of 94 total)
  • Well just updated to 2.8.1 Beta2 and having the same issue… STILL! ii have to save the post and then upload all the images to get it to work.. This is getting annoying fast haha.

    Had the Same problem uploading images using 2.8 I deactivated all plugins and added them back one by one and found that Position Yourself plugin was the reason my image uploader was not working. It is working fine now that I deactivated it and now I am about the delete it.

    TRY THIS…
    If you are using a custom directory to upload your photos in 2.8, there is only one way I found out how to make it work. With a fresh install, in the “Setting/Miscellaneous” under “Store uploads in this folder”, I put “uploads” (instead of the default ‘wp-content/uploads’) and for “Full URL path to files” I put “http://www.mywebsite.com/uploads” then clicked the “Save Changes” button. Then by using a FTP client, I had to CHMOD the Permissions settings for the newly created “uploads” directory to “777” before attempting to upload an new images while adding or updating any posts.

    I’m also having the same problem as most here with WordPress 2.8 ie. Images won’t upload using the flash/or browser media uploader – I get an http error.

    After some testing I’ve found I can upload a jpeg of 500px x 500px if it’s saved around 100kb, but not if it’s saved at 200kb.

    So it works after a fashion so long as images have a small filesize.

    Any thoughts?

    same, same, no difference for me! RAAAAAAA… pulling my hair off!

    Problem still there for me in RC1

    I am having the same problem with 2.8 as so many other WordPress users are.

    Clearly the time to fix 2.8 is here!

    image uploader doesnt work – uploads image ok – it is there in the folder but post dislays caption only – works fine if I upload image to an /images directory of my own making and inserting into post w html.

    This is not the usual WordPress “things that just work” that I have come to love.

    Well I’ve upgraded to 2.8.1 and it still doesn’t work properly. Small files <100kb ok, larger files >100kb give an unhelpful ‘http error’.

    Sankho

    (@sankho)

    I figured out a fix, it worked for me at least. Check out my blog http://blog.sankhomallik.com/2009/07/28/wordpress-28-media-upload-issue/

    kp studios

    (@kp-studios)

    I found this not to be related to any plugins. My current workaround was to save the post as a draft before trying to upload any images.

    If someone else could confirm this, that would be great – vineetsharma / da3M0n

    thanks for that tip, it worked a treat

    niekvugteveen

    (@niekvugteveen)

    http://wordpress.org/support/topic/254480?replies=9#post-1155091 Other topics and a possible solution can be found here.

    marketing_guy

    (@marketing_guy)

    I’ve had this problem after moving my wordpress installation – it’s advisable to check the miscellaneous settings and see where your files are being uploaded to and change accordingly

    koolvn

    (@koolvn)

    I was having same problem with my host but no problem to run same wordpress 2.8 with same theme on my local wamp as well as testing on my friend’s free host account. Since I’m running my own web server wamp for developing and testing, I’ve tried to lower a lot of different server settings in order to duplicate the error. Finally, found out that my wamp is always update to latest version of apache, mysql, and php and my friend’s free hosting account is php5 w/ mysql5 while my host still mainly run on php4, and after switching to php5, the problem are gone. Thus, I finally can insert images into post as you can see here in my free templates website

    http://themes.jlbn.net

    So make sure to check with your host if they still runs php4, and ask them to switch to php5 for you 😉

    glutenfreepost

    (@glutenfreepost)

    -Yep, they are running php5.2.something and I have checked the image upload location and they are set correctly.
    -I have tried saving the post as draft without uploading images, no change
    -I made sure the settings in admin/settings/misc were “wp-content/uploads” no change (they were already set to that.
    -Upgraded to 2.8.1 no change

    I do want to make sure I am clear about one thing. I DONT get an error. The image DOES upload into the server. It just wont display in the post/visual editor (which doesn’t work either)/or HTML editor. So what I have to do is code in the typical…
    <p style=”text-align: center;”><img src=”http://zxzxzxzxzx.com/wordpress/wp-content/uploads/2009/08/elle0.jpg” alt=”elle0″ width=”240″ height=”165″ class=”attachment wp-att-894 centered” /></p>
    …every freakin time.
    So with that…does the http://zxzxzxzxzx.com/wordpress/wp-content/uploads/2009/08/elle0.jpg mean that I have these pointed wrong? Should ALL images reside in only the uploads directory, can they or can they not be organized by month/year?

Viewing 15 replies - 46 through 60 (of 94 total)
  • The topic ‘Image upload not working in WordPress 2.8’ is closed to new replies.