Support » Fixing WordPress » Image Upload not working in 3.5

  • Resolved databell96


    I just upgraded to 3.5 for one of my clients and now I’m afraid to do it for anyone else. I get this message when I try to upload an image:

    An error occurred in the upload. Please try again later.

    What’s going on here?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Moderator keesiemeijer


    – reading the troubleshooting 3.5 master list to see if any of your problems is listed there:

    – flushing any caching plugins you might be running, as well as server and/or browser caches.

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems.

    – re-uploading all files & folders – except the wp-content folder from a fresh download of WordPress. by using FTP or whatever file management application your host provides (Manual Update).

    – re-running the upgrade via wp-admin/upgrade.php

    Thanks. It was a plugin. Magic Fields is causing the issue.

    For me, it was my theme (Thesis 1.8.5). On the upside, I’ve been meaning to get a better theme anyway, and this gives me motivation to make that sooner rather than later. 😉

    Getting the same error. Rolling back my update.

    Any of you guys know the specific thing that’s causing it (the specific code causing this error)?

    I’m running into it as well using a variation of BootstrapWP theme, but I have it working using that theme in another location (can’t figure out what’s different, as the two installs are on the same server).

    I have had no problems with this on other sites but it just blew up on a client site … I’ve tried all the fixes, deactivated plugins, changing to the default theme isn’t helping either. I can’t believe that lots of folks are reporting the same issue (I’ve seen posts across the web for the same problem) with no reported solution yet?

    No idea what’s going on with this one but I’m going to have to roll back the site to an earlier WP version now 🙁

    I have the same problem. Image uploader is not working. When i clicked on featured image Image uploader is pop up is come none action it will do. neither upload file is work nor any image get selected as feature image. It is going stuck close button is also not working.

    Same problem with me.

    Fresh install, default options, no plugin’s activated and image upload fails with error.

    Image shows under media but cant insert into post.

    Similar symptoms here. Fresh install of 3.5, no plugins activated, tried Twenty Eleven & Twenty Twelve.

    Upon uploading I get Error “An error occurred in the upload. Please try again later.”

    But the images DO upload (file manager verifies this), but the Media Manager does not always acknoledge it. Going out then back into Media Manager shows the uploaded image, but it seems that different size images don’t get created. I can then insert an image, but there’s no option for different sizes, and it is uploaded at the largest size.

    Seems like the error is that the thumbnails don’t get created.

    I’m using WordPress 3.5 and I also had the same problem. I read somewhere that adding:
    define('CONCATENATE_SCRIPTS', false );

    to the wp-config.php file will solve the problem. That fixed my issue.

    The line has to be before:
    require_once(ABSPATH . 'wp-settings.php');

    Mine is after:
    ‘define(‘WP_DEBUG’, false);’

    Hope this help!

    I had the same problem but found out that when I disabled and tried to re-enable my ProPhoto3 Theme Compatibility Patches plugin, it told me that I needed to actually delete this plugin and redo the process in order to update it. It’s the same plugin but for some reason I needed to go through this process in order to be the most up to date. It was odd because I didn’t get a message saying it needed to be updated, I only knew after I tried disabling all of my plugins to see where the problem was. Anyway, that fixed my picture upload problem! Hope that helps ; )

    I’m having the same problem and I’ve checked all file permission. It just won’t show on website, and thumbnail is not created properly.

    this is my 2nd site i tried with 3.5. The first site won’t show visual editor. This 2nd site won’t show images

    I’m going to revert back 3.4

    Also using 3.5 trying to load a photo on a local site. I get the message File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini. How do I fix this?

    Hey guys, after reading every single post on this issue, I found that by just doing a re-install of the latest word press version (3.5.1) from the dashboard or the update tab, everything worked fine.

    media uploads … OK
    media library … OK
    links to pics … OK


    Even if you already have the latest, just re do it again!

    Try that before busting your head with all of the other tech heavy stuff.. Good luck guys!

    @latin625 Thank you, simply re-installing WP solved the problem for me.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Image Upload not working in 3.5’ is closed to new replies.